ABP activation lost

Guys,

I expose here a strange behavior, or at least strange situation that I would like to explain in order to keep trust in LoRaServer (I have no doubt but I need to find the reason to avoid such a situation in the future).

So I Commissioned devices using API interface in ABP mode (creation + activation with keys), and all worked fine (device received many times).

Many weeks passed, and I see that a non-negligeable part of my devices are not received any more on Application Server level. After investigation, it appear that these devices lost its keys (verified by API reading) like they are now disactivated.
Actually, I am not sure who’s got access to the device management interface during that time, so no way to determine if this was caused by a user mistake.
I saw that device creation date can be recovered, but what about last modification date? Or something like this? Can I get more info about the device configuraiton change history?

In the loraserver.toml file is a keyword “device_session_ttl”. Maybe the time was expired? :slight_smile:
See this

BR/DeHi

Hello, I have encountered a similar problem, have you solved it?

I have the same problem, anyone found a solution? Over 500 devices disactivated :confused:

This could be a Redis misconfiguration. Please see: https://redis.io/topics/persistence.