Can't connect to PostgreSQL after upgrading LoRaServer --> Chirpstack (Docker installation)

Hi everyone,

I’m actually struggling, probably on a little step i missed.
I’m willing to upgrade my LoRaServer to ChirpStack, in my Docker installation, without losing the data of my LoRa devices.

Following @brocaar’s announcement (by the way, you’re amazing! thanks a lot for your work), and some other topics found in the community’s forum, I updated both docker-compose.yml and docker-compose-env.yml files with the new names of the images:

  • loraserver\loraserver --> chirpstack\chirpstack-network-server
  • volume: ./configuration/loraserver --> ./configuration/chirpstack-network-server
  • directory: loraserver --> chirpstack-network-server

And so on, renaming also the other components and directories.
I stopped the containers loraserver, lora-gateway-bridge, lora-geo-server and lora-application-server, and then i ran the compose.
The bad thing is that when i build the stack with the new images with docker-compose up, looks like the application server and the network server can’t connect to PostgreSQL, even if i didnt change the name of the services in the files and the credentials of the components (i left loraserver_ns and loraserver_as for PostgreSQL in docker-compose-env.yml file), getting the error “connection refused” for PostgreSQL.

Edit: i can’t even reach the application server on my browser, after running the stack…

What am I missing?
Thank you for any kind of help!

maybe you miss the edit the .toml files with right db name and user/pass credentials for successful connect
inspect the postgresql error log for more clearence of understanding your issue

Hi @eugenev, thank you for your help.

Actually i found i mistyped a configuration file name (i wrote netwrok instead of network). Everything runs ok, i can reach ChirpStack’s login page, but still can’t login and see my devices.
I’m trying to restore a dump from my Redis and PostgreSQL in the new containers, and then restart anything, lets see.

Edit: Actually i can log into Chirpstack, but still i can’t see my devices…

Actually my docker-compose builds another PostgreSQL and another Redis database container, tried to restore the respective dumps from my previous installation, but with no success.

Edit 2: worked :slight_smile:

look into the logs and it will bring you closer to a solution.