Can't get AU915 to work on any device. AS923 works fine

Hi everyone,

First off I’m not the best with LoRaWAN or radio. I just want long range communication, it’s all very confusing to me.

I have a RAK831 + Raspberry Pi for a gateway. I use the RAK firmware on it.

I login via SSH and run sudo gateway-config and from there I can set the channel-plan configuration and if I want to use Chirpstack or TTN. I have this all set up with AS923 and it works fine! No issues, flawless.

But my Arduino also supports AU915, and I’m in Australia, so I would like to use AU915. I also have another temperature sensor that only supports AU915 and I cannot get it to work either.

I can see join requests in the data section of Chirpstack but it fails to OTAA and won’t send data.

I suspect it has something to do with the multiple channels AU915 offers? All websites seem to call these different channels or band-plans but I have no idea what I’m doing. TTN apparently uses band-plan 2 and I would like to first set my devices to use band-plan 2 and see if they work, and then later change this to another band-plan since I’m not using TTN so why use their band-plan?

But I don’t know what my server is set to, and how to change it? You used to set the channels in a gateway-profile but this is deprecated and I can’t set it anyway. There’s no option to link a gateway to a gateway-profile anymore.

I assume it’s a configuration file I need to edit. Could anyone help? There’s not much online for AU915. :frowning:

Thanks in advance. I’d love to use AU915. :slight_smile:

Hi @aaroncm,

I would suggest you to read this carefully:

Basic things you will need to adjust in network-server config regarding channel plan would be:

  • []
  • enabled_uplink_channels
  • [[network_server.network_settings.extra_channels]]

That way you should be able to set all channels you would like to use.

Then you should make sure to keep that setting in sync with your gateway channel settings which you will have to do manully, probably just as you did with sudo gateway-config (but I’m not familiar with RAK-based gateways).

Hi Martin,

I currently have all uplink channels enabled but I did try to set them to 8, 9, 10, 11, 12, 13, 14 ,15, 65.

But that didn’t seem to help.

I have an Arduino MKR WAN which doesn’t actually let me set the sub-band but I can only assume it’s designed to work with TTN as all of Arduino’s examples use TTN. So I assumed it would use sub-band 2.

I also have a Dragino sensor and it’s pre-configured for AU915 sub-band 2 out of the box. From the manual:

Default use CHE=2
916.8 -SF7BW125 to SF12BW125
917.0 -SF7BW125 to SF12BW125
917.2 -SF7BW125 to SF12BW125
917.4 -SF7BW125 to SF12BW125
917.6 -SF7BW125 to SF12BW125
917.8 -SF7BW125 to SF12BW125
918.0 -SF7BW125 to SF12BW125
918.2 -SF7BW125 to SF12BW125

923.3 -SF7BW500 to SF12BW500
923.9 -SF7BW500 to SF12BW500
924.5 -SF7BW500 to SF12BW500
925.1 -SF7BW500 to SF12BW500
925.7 -SF7BW500 to SF12BW500
926.3 -SF7BW500 to SF12BW500
926.9 -SF7BW500 to SF12BW500
927.5 -SF7BW500 to SF12BW500
923.3-SF12BW500(RX2 downlink only)

I think I will focus on getting the Dragino to work first. But I’m not sure where to go. When it attempts to OTAA I usually get an uplink join request, and then a downlink join accept, both on the same frequency (example 917400000) but nothing else happens and the device fails to connect.

Could there be anything obvious I’m missing?

Thank you!