Channel plan for device


We have connected a sensor to our loraserver and we are suppose to be getting uplinks every 5 minutes while we test for the motion detection. But we are seeing intermittent uplinks, our sesnor vendor says we have to push down the correct channel plan to the sensor for this to work properly.

Any ideas where we set this?

Here is the response from our sensor partner, any ideas would be very helpful!!

You will need to push down an 8-channel plan from your network server to the device once it is joined to the network. I’m not sure how your server is setup, but this is accomplished using the ‘LinkADRReq’ command in LoRaWAN

Hi sconner,

If you have an ABP node, you can set factory preset frequencies in the device profile.
However, if you use OTAA devices, the frequency plan is exchanged between server and node. You can enable additional channels in the file loraserver.toml.

Best regards

Hi, thanks for your reply. Are device is using OTAA, and none of the changes we make to the enabled channels for the device change the channel mask. Has anyone else had any issues with this.

It seems that the channels are enabled.
Which devices do you use?
Can these devices use more than the 3 standard channels?


But my question is why am I seeing these channels enabled, when we are setting the enable uplink channels in the loraserver.toml to [0, 1 ,2 ,3 ,4 ,5 ,6 ,7] My understanding from the documentation is that we should only see the first 2 channels set to true

We are using a 16 channel gateway in the US 915 band with a gateway profile set to 0 for channels and service profile is set to 0 and 0 for data rate