Chirpstack network server installation

Hi to all, I am new to this community as well as Ubuntu and Chirpstack. I get a simple error when trying to install the network server. I followed the installation guide on the chirpstack site. Successfully install ed the gateway bridge as described. When I get to the network server install:

sudo apt install chirpstack-network-server

I get:
Reading package lists…done
Building dependency tree
Reading state information…done
E: Unable to locate package chirpstack-network-server

Then I get my prompt back. I have been trying to install with all files residing on my desktop so I was sure the files are in the same directory…

Any ideas?

Thanks much
Rob Kristiansen

Hi Rob, lets try this command and post results: cat /etc/apt/sources.list.d/chirpstack*.list

My guess is you are trying to install v3 network server using v4 guide (or at least repository).

HI Martin,
I ran that command at the Desktop$ prompt.
I got a response:
deb Index of /packages/3.x/deb/ stable main

Hi Martin,
Not sure why my post changed… The response I got from the computer is…I will put it in quotes…
“deb Index of /packages/3.x/deb/ stable main”

Not sure what is happening but the wording “index of /packages/3.x/deb/” is not correct. I will take a screenshot to make better sense of this

Forum has some autoformatting tools so the address got converted to link automatically. You can use markdown formatting (backticks in this case) or use Preformatted text button in the reply dialog tab which adds the backticks for you.

But anyways, that looks like correct v3 repository, so it should work. I would try sudo apt update again, then you can also check apt-cache madison chirpstack-network-server

In worst case you should be able download and install the packages manually (see Download section in the Docs).

HI Martin,
Thanks for your quick response. I wish I knew this Ubuntu environment better. I really do not have a handle on the file structure etc. I in my earlier computing years was very good with DOS. Anyhoot I tried the commands you suggested and got this.

Hi Martin,
Quick thought on my install troubles… I see the installation guidelines say the install was tested on Ubuntu ver 18.04 LTS. i think mine is a newer version like 22? could that be giving me these install issues?

Thanks Rob

Could be, but I wouldn’t expect that. But judging by your wallpaper and “focal” in your screenshot it means you are running Ubuntu 20.04 and for that I can confirm both v3 and v4 Chirpstack is working. No Idea what is causing the error you see.

I can suggest you two options if you want to get chirpstack up and running:

  1. Try installing v4 instead and see if it that works. Keep your v3 gateway bridge (don’t install v4 GW bridge) as it is compatible for both v3 and v4 (if one of latest versions).
  2. Download and install the AS and NS precompiled binaries manually ( for example). You should be able to install it simply by right clicking the downloaded archive → open with other application → Software install.

BTW: I started using linux few years ago actually because of Chirpstack too. Now I only ask why I didn’t do that earlier.
Takes some time to get used too, the biggest change in the beginning is probably the folder structure - most of the time you don’t actually install any apps to single folder like you may know from Windows. Instead, installation scripts basically unpacks parts of the software to various folders which has ceratin functionality in linux system. For example the /etc folder will contain configuration files for most of your apps, but app executables are somewhere else.

Two random tips: 1. Try midnight commander (mc). 2. On Ubuntu you can make screen-cuts with SHIFT+PrintScreen and selecting the part of screen you want to save to picture which wou will then find in your Pictures folder.

HI Martin,
I tried your fix… I am still a little stuck… I could not find the V4 applications. I did download V3 of Network Server and got it installed as you suggested. That said the install appeared to go correctly but I cannot find the .toml file for the network server. I looked in the /etc directory.

I then tried to install the Applicaiton Server which I again could only find as version 3.17 + . During the install the screen comes up to a loading application gray screen and just stays there. Tried a couple different releases of the package and got the same result.

Glad to hear I am not the only one who started with the need for Chirpstack. I wish to deploy a local Server for LoRa so we can do some in-house development of remote sensing. We would like long term to automate data transfer and collection for monitoring wells and flow rate data from dikes/ dams.

Thanks Much

Rob Kristiansen

Hi Martin,
So far I have not been able to complete the installation of the Chirpstack components. I am thinking since I have had such difficulty that I should start fresh and do a new Ubuntu install on this computer without dual boot and maybe a newer version. What version of Ubuntu do you think I should install?

Thanks Rob

Hi Rob, well I was thinking about that because that behaviour is unussual (at least for me). In general you are always safer to go with LTS versions and upgrade to next version at least year after it was released or even when following LTS version is released. I would stay on 20.04, which work really well for me.

I’ve tried 22.04 on one older PC (which is still good for multimedia) and ended up reinstalling 20.04 as the newer version didn’t really bring anything better to it, but the performance degraded significantly. Also some extensions were not updated yet, so even user experience degraded.

Edit: or hold on, seems you are not the only one with this problem: Certificate verification failed The repository does not have a Release file