Chirpstack on the gateway! Yes or no?

Is it necessary to have chirpstack installed on the raspberry pi 3B gateway with the SX1301 hub?

It’s fully depends on your decision, where and how to deploy chirpstack to control your LoRaWAN network.

Thanks Eugenev! good answer … that helps me to stay more oriented, that means it is not necessary!
The implementation that I try to carry out is the simplest possible;
in debian buster I have installed chirpstack-gateway-bridge chirpstack-network-server chirpstack-application-server working everything correctly, I think …
and on the gateway the PG1301 hub based on SX1301 and pi_gateway_fwd-master.

I’d recommend to install the gw-bridge on the gw. UDP needs to get more love from ISP/MobilCarriers. Some are quite “aggressive” dropping “flows” to quick if there is no package moving, with the gwb at the gw, you can (with some limits) try to mitigate that (MQTT QoS)

1 Like

the MQTT broker can be deployed external to the gateway.

Gracias Chopmann !
So the trick is to fine tune the file;
Gateway /etc/chirpstack-gateway-bridge/chirpstack-gateway-bridge.toml
trying to point it to the MQTT installed on debian buster along with the Chirpstack suite, so it doesn’t complain; journalctl -f -n 50 -u chirpstack-gateway-bridge
giving the MQTT error

buenas paco. Remember: You are the one in front of the computer, and even if Elon/Zuck are trying to plug us directly to the computer, I am not able to “see” your error from here. Provide as much information as you can, else we are wasting our time playing guess games and not actually debugging. You can use pastebin or the formatting tools in the forum to upload: configuration (remember to delete credentials and/or change the server-names, log-output (sensitive information should be removed) and if you are really really nice, a diagram describing your setup. That way we all have a better understanding of what you are trying to accomplish - besides now you got a bit of documentation on your project.

from the logs it looks like it’s working

¿It could have something to do with the fact that the time of pi_gateway_fwd is delayed one hour with respect to chirpstack-gateway-bridge

might be. Could you upload the configuration of the NS, AS, GW and your packet-fwd to pastebin/gist?
Also for the logs - it’s a bit hard to read them like that.
Remember to configured the proper frequencies for your hardware and region, a mismatch will lead to strange errors.

It’s okay! Let’s see how you see these files, after your answer I’ll keep changing things … I’ll also have to learn to use pastebin better.
the word ““usted”” seems unknown to the google translator.

NS https://pastebin.com/Ws1QJazw
AS https://pastebin.com/JNEUJkmK
GW https://pastebin.com/NuiGAzQn jj5Hg0VvYn
paquete-fwd https://pastebin.com/8wBbWxTK

http://paste.debian.net/1181083/

Very practical pastebinit, yes.
I have deleted a message for clarity.
Maybe too! a clear example of how to put the ID of the gateway in AS, would be very nice.
Thank you for your patience…

Your NetID should be 000000or 000001 (I’d stick to the first)
You should try your config without tls - I think you might be confusing how it works.
For the gateway_id you just need to copy the one in the global.conf or local.conf if it’s getting overwritten.
You have to “add” it to the NS/AS else it wont show nor it will process traffic.
Can you post a screenshot of the gateway added?

Enabled channels should be 0,1,2
Your extra channels are 3-9
Something like: https://imgur.com/a/8V6upIY

take note.
But I don’t distinguish between NetID and gateway_id

NetID is for the “whole network” it goes in the toml (just use 000000)
Gateway_Id seems to be fine. The profile does not and please make sure the device you are trying to connect is also for EU.

Thanks Chopmann! I will try little by little …

this on the gateway;

Example:

net_ids = [

“000000”,

“000001”,

#]
net_ids = [
“000000”,
]


You have to “add” it to the NS / AS, otherwise the traffic will not be displayed or processed.

I don’t know where to put the gateway_id in NS and AS

My intention is to check that the WG, NS, and AS work well, the main thing, it is clear that there is communication between NS and AS, but not between WG and NS.
Once its operation is clear, it would connect a device. To make the installation in steps, simpler, is it possible to check it without connected devices?
You should see some indication of communication between WG and NS!

just net_id="000000"
From the screentshot it looks like you have already installed the gateway properly. I said the gateway-profile is wrong. You might need someone to look at the configuration and your setup with you. I dont think I’ll be able to help you further.

thanks for everything Chopmann!
has helped me lay the foundations …