Chirpstack Python API


I run into the following issue using the python example cope given for the HTTP integration at HTTP - ChirpStack open-source LoRaWAN<sup>®</sup> Network Server

Somewhere in the Parser function from google protobuf the exception is thrown

google.protobuf.json_format.ParseError: Message type “integration.UplinkEvent” has no field named “publishedAt” at “UplinkEvent”.
Available Fields(except extensions): “[‘applicationID’, ‘applicationName’, ‘deviceName’, ‘devEUI’, ‘rxInfo’, ‘txInfo’, ‘adr’, ‘dr’, ‘fCnt’, ‘fPort’, ‘data’, ‘objectJSON’, ‘tags’, ‘confirmedUplink’, ‘devAddr’]”

Any idea what is going on? Since the json obeject has the field publishedAt with a timestamp…

Did you find a solution for it? I’m having the same issue.

1 Like

No I didn’t get it to work and no response in the form. I set up a custom host if TTN. Community support there seems better.

I’m on the same path.

Which version of the chirpstack-api did you install? Have you tried the following command:

pip install -U chirpstack-api

I’ll update the docs to make sure that it mentions the latest version.

I´m using chirpstack-api-3.7.2.
I will try the new version.

Now, everything is okay, thank you very much for the response.