Devices are disconnected from Server

Hello everyone ,

Unfortunately, I have a big problem. This problem has occurred twice since last week.
Devices can not even communicate with the gateway. In the AP-Server-application- LORAWAN FRAMES, I do not see any logs, to do this, I must reset the devices to rejoin them to NS server.
I have read all NS logs since the last packet was sent, everything is normal.
Please imagine that the devices are in different cities, sometimes in remote areas and it is very difficult to reset them every time. Does anyone have this experience? And the question is, what causes the devices to have to be rejoined?
Chirpstack AP version 3.14 and NS version 3.12.3 are installed on GKE(Google Kubernetes Engine) and GW Bridge on physical GW…

maybe do i need to upgrade to new version, if there is any bugs ?!!

Any response please?!!

It’s unrealistic to expect someone to help, if this is the case. You need someone on the ground who is familiar with LoRaWAN and, ideally, your project.

  • Are all sensors doing this or just some models? If some models or all are the same model, open ticket with OEM - might be a known issue.
  • Are all gateways doing this or just some models?
  • Can you add a “known good” gateway and a “known good” sensor to have a way to validate that it’s not you transport that’s at fault? If you get your “known good” data but NOT your “remote” data, you will know more than you do now!

I agree with @fmgst that it is difficult to provide you with a good answer. Maybe a hint:

This problem has occurred twice since last week. Devices can not even communicate with the gateway.

Are you sure that the channel-plan in ChirpStack matches the channel-plan of your gateway? If your gateway doesn’t receive data from your devices, then it could be that the devices are using frequencies that are not configured on your gateway.

I tried to monitor this problem last week. In one place, the connection problem between the devices and the gateway was loRaSNR = -15.
Elsewhere I have an Lorix-one gateway, which is the default setting. I did not give it any Channel-plan. Do you think I must do this on both Chirpstack NS and Gateway- bridge that installed on GW?
If yes, how should this be done?