Downlink always send

why my applications always send downlink after the uplink data arrive, even i already flush the device queue? and i dont what it is, because my node cannot read it


Because the Network Server will want to modify some operating parameter of your device, for instance, Data Rate.

Why cannot your node receive anything?

Hello pulidoj, thanks for your response, to be honest i don’t know network server will modify my data rate’s node. Maybe that’s why my node always read that downlink every time i send uplink data.

I using Beelan-LoRaWAN library in my node, the node will read and print the downlink, but i cant read it. I set my own downlink in Enqueue downlink payload but my node cannot receive that, because this downlink.

This is what i see in my gateway Live Lorawan Frames:

and this is what i see in my serial monitor on my node:

Is that any possible to disable that automatically downlink? so i cant send my own downlink payload, and my node can receive that. Because when i use this library, its work fine in TTN downlink.

Hi @radonsstk_record,

The LoRaWAN network is a "smart"network: this means that it is not only to communicate from end nodes to server sending some kind of messages.
It is also a network with communication from LoRa Network Server (Chirpstack in our case) to end nodes.
These downlink messages could be

  • Custom messages as the one that you sent manually.
  • Network (ADR or MAC) messages where the Network Server sends different commands to the end nodes.

If your end node is 100% LoRaWAN compatible it will understand these commands but as your case you are not processing them, so the Network Sever continues to send downlink messages.

You can disable downlink messages (ADR & MAC) both in .toml configuration file of Network Server.

  # Disable mac-commands
  # When set to true, ChirpStack Network Server will not handle and / or schedule any
  # mac-commands. However, it is still possible for an external controller
  # to handle and / or schedule mac-commands. This is intended for testing
  # only.

  # Disable ADR
  # When set, this globally disables ADR.