Downlink not getting sent to Sensors

Downlinks are not being sent to the sensor. I can confirm that the data queued in network server is received at gateway, but the chirpstack throws the below errors:

  1. log downlink frame for device error chirpstack
  2. log downlink frame for gateway error

I am kind of confused where is the actual issue. I am trying to figure out the issue. It would be great if anyone could suggest me why does chirpstack throw this error and usually when this kind of error is thrown. Any help would be appreciated. Please find below the sensor, gateway and downlink payload details. Also, find the logs of network server and gateway.

Gateway: Tektelic Kona Enterprise Gateway
Sensor: Sensative Strip Presence Sensor
Downlink Payload (Hex): 0103010000002F0000001E3100000258300000001E
Downlink Payload (Base64): AQMBAAAALwAAAB4xAAACWDAAAAAe
Downlink Type: Confirmed
Downlink FPort: 11

Gateway Received Payload:

JSON up: {“rxpk”:[{“tmst”:816190772,“chan”:2,“rfch”:0,“freq”:902.700000,“stat”:1,“modu”:“LORA”,“datr”:“SF10BW125”,“codr”:“4/5”,“lsnr”:8.5,“rssi”:-99,“size”:24,“data”:“gJgYBwGAVAABPaoocvjoFAgd6nc5LFKj”}]}

JSON down: {“txpk”:{“imme”:false,“rfch”:0,“powe”:20,“ant”:0,“brd”:0,“tmst”:817190772,“freq”:924.5,“modu”:“LORA”,“datr”:“SF10BW500”,“codr”:“4/5”,“ipol”:true,“size”:35,“data”:“oJgYBwGhLAAGCy0rWv2Sg+9IdkJ0mIz0sluKDor4EVvZb5c=”}}

Chirpstack Logs of same Device:

Since the error comes from Redis, perhaps there is something wrong with Redis? Have you tried looking at its logs?

By the way: if the downlink was logged in the gateway, it is already past this point. If your node didn’t receive the downlink, the problem might be elsewhere.

No, i tried sending the downlink with another gateway and a different sensor. It is working perfectly fine. So i think the Redis is fine i guess. It has to be with the gateway or the node but I am not understanding if the error is with the gateway or the node. If i could understand what this error from chirpstack specifies then i would be able to debug the issue.

I think still you could break this down into two problems.

  1. It is not necessarily a problem within Redis, but a problem with Redis. Does it happen consistently? If so, then what is this “previous error” that your screenshot shows?

  2. The downlink packet was received by the gateway. Assuming it contains the data you meant to send, was it successfully sent by this gateway? Further log messages should indicate whether it was a success or not.

Thank you for the above help, I think I discovered the issue. I think it was because of the signal strength of the sensors, the sensors with good signal strength received the downlinks. I feel the above issue came for the sensors with lower signal strength, I am trying to install few more gateways to increase signal strength. I can confirm this only after I test installing more gateways.