Empty Gateway-Dashboard (Received / DR, Transmitted / DR)

In my Chirpstack-Test Installation in Version 4.6 i have the following issue:

The Dashboard shows no statistics for (Received / DR, Transmitted / DR). Any other statistics are show.

when i check the data via API, i can see that no values are stored.

part of the API Request answer:

‘txPacketsPerDr’: {‘name’: ‘Transmitted / DR’, ‘timestamps’: [‘2024-06-19T00:00:00Z’, ‘2024-06-20T00:00:00Z’, ‘2024-06-21T00:00:00Z’, ‘2024-06-22T00:00:00Z’, ‘2024-06-23T00:00:00Z’, ‘2024-06-24T00:00:00Z’, ‘2024-06-25T00:00:00Z’, ‘2024-06-26T00:00:00Z’], ‘kind’: ‘ABSOLUTE’}

→ there is no dataset, as in other metrics

Any idea how to solve this issue?

can anyone help with me…
would be important for my project :smiley:

thanks

Dont face this issue on Debian deployment. All my fields are properly populated. Did you try restart server,etc?

my chirpstack installation is on docker containers (two, with lb infront of it).
i have restarted the cointainers - but this does not help

one more update…
i digged a bit in the redis database. there i found the key for on of my gateways / metrics:

127.0.0.1:6379> hgetall “metrics:{gw:****************}:DAY:202405070200”

  1. “rx_freq_868500000”
  2. “4518”
  3. “rx_dr_4”
  4. “8”
  5. “tx_dr_0”
  6. “3”
  7. “rx_ok_count”
  8. “20462”
  9. “rx_freq_868300000”
  10. “4439”
  11. “rx_freq_867500000”
  12. “1046”
  13. “rx_dr_0”
  14. “8275”
  15. “tx_dr_1”
  16. “1”
  17. “tx_ok_count”
  18. “83”
  19. “rx_freq_867300000”
  20. “1747”
  21. “tx_freq_867900000”
  22. “6”
  23. “tx_freq_868500000”
  24. “11”
  25. “rx_dr_2”
  26. “28”
  27. “rx_freq_867100000”
  28. “1668”
  29. “rx_dr_1”
  30. “529”
  31. “rx_dr_3”
  32. “332”
  33. “rx_dr_5”
  34. “11290”
  35. “rx_count”
  36. “26017”
  37. “rx_freq_867700000”
  38. “1456”
  39. “rx_freq_868100000”
  40. “4418”
  41. “tx_status_OK”
  42. “83”
  43. “tx_freq_868100000”
  44. “9”
  45. “tx_freq_867700000”
  46. “9”
  47. “tx_freq_867500000”
  48. “11”
  49. “rx_freq_867900000”
  50. “1170”
  51. “tx_freq_867100000”
  52. “13”
  53. “tx_dr_5”
  54. “79”
  55. “tx_freq_868300000”
  56. “12”
  57. “tx_freq_867300000”
  58. “12”
  59. “tx_count”
  60. “83”

as it looks, my metrics are stored in redis.

but as soon as i use it via GUI or API, it is emtry. also the chirpstack logs write out its okey:

2024-07-05T09:28:40.815032Z INFO gRPC{uri=/api.GatewayService/GetMetrics}: chirpstack::api: Finished processing request status=“200” latency=3.820106ms

Have it ever worked before for you?

In chirpstack.toml, have you ever changed key_prefix under Redis configuration?

no, i have never set a key there. it was always empty.

  # A key prefix can be used to avoid key collisions when multiple deployments
  # keys by database index (e.g. when using Redis Cluster, which does not
  key_prefix=""

Let me know if you find the answer.

I do not have those informations displayed, but not sure my gateway is sending them.

no, i still have the same issue. but i found out, that my post from before is wrong. in redis, i do not have the data anymore since i migrated from chirpstack v3 to chirpstack v4.

so new keys do not have these data. the gateway bridge is still on version 3.14.x - so i have the feeling it could be this.

what gateway bridge version do you use?

i am out of office for the rest of the week - but i will update gateway bridge next week and check if it is better with a new version of gateway bridge.

regards

sudo chirpstack-gateway-bridge version
4.0.11

i now had the chance to update the gateway bridge to 4.0.11

and it works now - so for me, it was a old chirpstack gateway bridge version.

thanks for your help

1 Like