Error: bind: address already in use

Hi, I am using RisingHF Gateway concentrator with Raspi. We encountered error when running the lora-gateway-bridge, Here are the error message :slight_smile:

INFO[0000] backend: connected to mqtt broker
INFO[0000] gateway: starting gateway udp listener addr=
FATA[0000] could not setup gateway backend: listen udp bind: address already in use

Can you help to resolve this ?

I think there might already an other service running on your RaspberryPi listening on port 1700 (UDP). You might find this article helpful for debugging:

OK, Thanks for your tip. It really helps

1 Like


I am getting the same error, I have tried to setup the bridge on the gateway itself, so when I try to connect to aws iot core i get this error on the gateway.
I do not see any other process running on the same port or the gateway.
Could you please help .

Thank you.

i also have got same problem when i checked the port is being used by lora-gateway-bridge only but still its showing the error

did you ever solve this?

After updating my Ubuntu 18.4 to 20.4 i suffered the same problem and the caus was that the packet-multiplexer now started before the gateway after the gateway was unable to start. Disabliing the packet-multiplexor for which i was unable to find any dokumentation on everything now starts up fine.