Gateway connected but no data/end node seen on Application

Hope You all are doing well !
I am using RisingHF + RPI as a gateway and successfully seen the gateway last status on chirp stack in gateway detail section . I am using local server .And as a end node / device using nucleo with sx1262mb2xAS .

Now issue is that , i am unable to see the application / device data on chirp stack server .
I tried to trouble shoot the issue , by following the trouble shoot section of chirpstack server and find the following logs , which seems to be ok but unable to find the exact issue . Logs are as follows

When i run the " journalctl -f -n 100 -u chirpstack-network-server"

i got following response

21 22:36:38 muhammad-VirtualBox chirpstack-network-server[966]: time=“2020-07-21T22:36:38+05:00” level=info msg=“finished client unary call” ctx_id=64a21ac2-20b5-43f1-bc8d-3fc5e5707413 grpc.code=OK grpc.ctx_id=72538408-2cc1-4098-9bea-8887793e68f9 grpc.duration=12.058674ms grpc.method=HandleGatewayStats grpc.service=as.ApplicationServerService span.kind=client system=grpc

muhammad-VirtualBox chirpstack-network-server[966]: time=“2020-07-21T22:36:43+05:00” level=info msg=“finished unary call with code OK” ctx_id=945c53f0-5449-419f-8086-99aad536a846 grpc.code=OK grpc.method=GetGateway grpc.service=ns.NetworkServerService grpc.start_time=“2020-07-21T22:36:43+05:00” grpc.time_ms=4.168 peer.address=“” span.kind=server system=grpc

22:37:00 muhammad-VirtualBox chirpstack-network-server[966]: time=“2020-07-21T22:37:00+05:00” level=info msg=“gateway/mqtt: gateway stats packet received” gateway_id=b827ebfffe606395 stats_id=93db9d88-42e6-462d-a35d-90395b541e1a

21 22:37:00 muhammad-VirtualBox chirpstack-network-server[966]: time=“2020-07-21T22:37:00+05:00” level=info msg=“gateway updated” ctx_id=93db9d88-42e6-462d-a35d-90395b541e1a gateway_id=b827ebfffe606395

And when i run the following command
“journalctl -f -n 100 -u chirpstack-application-server”

i got the response as

muhammad-VirtualBox chirpstack-application-server[980]: time=“2020-07-21T22:39:30+05:00” level=info msg=“finished unary call with code OK” ctx_id=50e1c4bf-9c2f-4c08-a62f-7bc804f71d61 grpc.code=OK grpc.method=HandleGatewayStats grpc.service=as.ApplicationServerService grpc.start_time=“2020-07-21T22:39:30+05:00” grpc.time_ms=3.788 peer.address=“” span.kind=server system=grpc

21 22:39:38 muhammad-VirtualBox chirpstack-application-server[980]: time=“2020-07-21T22:39:38+05:00” level=info msg=“gateway updated” ctx_id=8b70e8bb-4e79-45f3-9410-2967c2167424 id=b827ebfffe606395 name=IOTGATEWAY

21 22:39:38 muhammad-VirtualBox chirpstack-application-server[980]: time=“2020-07-21T22:39:38+05:00” level=info msg=“metrics saved” aggregation="[MINUTE HOUR DAY MONTH]" ctx_id=8b70e8bb-4e79-45f3-9410-2967c2167424 name=“gw:b827ebfffe606395”

21 22:39:38 muhammad-VirtualBox chirpstack-application-server[980]: time=“2020-07-21T22:39:38+05:00” level=info msg=“finished unary call with code OK” ctx_id=8b70e8bb-4e79-45f3-9410-2967c2167424 grpc.code=OK grpc.method=HandleGatewayStats grpc.service=as.ApplicationServerService grpc.start_time=“2020-07-21T22:39:38+05:00” grpc.time_ms=9.948 peer.address=“” span.kind=server system=grpc

Thanks for the help in advance .

is your endnode successfully joined to the chirpstack server? b-cos there are none of uplink messages from endnode device.

1 Like

thank you Eugenev for the response ,

Sorry i am new to chirpstack , last time i connected the end node with loriot server . Same FW i have uploaded to my end node and tried to connect with the chirpstack server .

For this i have followed the following steps

  1. I have installed the gateway to my gateway RPI + RISING HF
  2. Installed the chirptack server , Application server and gateway bridge to the Server
  3. Run the packet forwarder
  4. Able to see the gateway status connected to the chirpstack server.
  5. Then uploaded the same firmware which was working fine with loriot server to the end node.
  6. Configured the network server and device on chirpstack server as per instrucations and enabled the OTAA option.
  7. Entered the Dev EUI , network and application key when selected the OTAA option .

What do you think where is the issue ?

Thanks in advance for the prompt response.

issue in what? You describe your steps, but not answer on my question.
For OTAA DevEUI and AppSkey is enough while adding the device to application.
Which version of chirpstack you are using?

Thank you !
sorry i am new to lorawan ,i am beginner.
Network server of version 3.9.0
application server of version 3.10.0

Issue is that , gateway is showing connectivity

But not showing end device data (last seen at never ) at shown in picture

Again Thanks for your prompt response and concern

stop focusing on it, it won’t help you

check the keys and DevEUI at the both sides (in the device and in the chrpstack)
Are you sure in that device is OTAA ? or really device is ABP?
look into the gateway live frames tab to sure in that device is sending frames.

1 Like


yes i have checked the DevEui on both ends , thanks for the hint may be issue is because of MSB and LSB .

Yes End device is OTAA enabled , i have loaded the i-cube-lorwan stack into the device . And i have successfully checked with loriot server and able to see the end device data on that .You are talking about live lorawan frames ? Thank you i will check all these in detail and update you . Thanks for your expert opinion .

Hi Eugenev,

I have checked the DevEUI on both sides , both are same .And i have checked the live frames tab as well . No data on that only busy for loading . I have attached the images can you please look into it .

What is your opinion where will be the issue .Thanks in advance for the concern .

Best Regards ,

look into packet forwarder log on your gateway, Is your PF configured for the right regional frequency band ?

1 Like

yes , i have changed the frequency to 915Mhz for US , previously it was 868MHz for EU . I changed it to global_conf.json file which was in the poly_packet_forwarder folder . But same result . :neutral_face:
Do you think there is another mistake ?

Thanks for the help and concern .Any hint ?

run poly packet forwarder with logging and look into it. does your gateway receives the packets from any LoRa endnodes including your. if yes, than make sure that the packets are received by chirpstack-gateway-bridge etc.
trace the entire LoRa-frame path.

Your gateway is fine. But your end nodes aren’t. What library do you use for the end nodes, because that is the issue?
The OTAA needs only APPSKEY and DEVUI key for connection no need for APPEUI, can be left empty.
I think you should check the order of the keys, MSB or LSB. and get back to us. Good luck