Gateway RAK7258 Last seen at never

Hello, i have a problem with my gateway, my gateway is (i think) correctly set up and it not appears as “working”, also the end devices (lgt-92 gps tracker), i need to know how can i solve this problem urgently. Thanks. Im using it in chirpstack server, not in ttn. @brocaar

maybe you attach some configs of your setup? we are not sorcerers to know what you configured there.

HAHAHAHA My bad brother, what do you exactly need? Configurations about what?

In fact, let me explain it, i installed the chirpstack server in a virtual machin (ubuntu 18.04), all of them (gateway bridge, network y app server) are active and running, but in the app server in the web (accessing with the vm ip and :8080 port) in the gateway in the last seen section it shows never (picture show it)

also the devices (im using the end node called LGT-92 gps and acc tracker). I have many days reinstalling and reading all the forums but none of those solutions works for me, if you need the logs i will show them. By the way, my gateway is the RAK7258 US915 Frequency.

ensure the gw-bridge is listening IP, which configured in the gateway packet forwarder

Its already set up, do i have to see it in the logs?

most likely, yes.
anyway inspect logs at the both sides

I reinstalled the gateway-brigde and it does not shows new logs, only says “Logs begin at with a date”, in the other case, the logs of the Gateway are these:

And these photos are the app server logs and the gateway bridge logs:

None of them says like a big error or something related to that.

from the first log there are no any packets received by your gateway from devices.
make sure in that your devices sending them.

I saw that the gateway bridge is in a loop of starting and stopping, in the logs of the network server i have the error: level=error msg=“gateway/mqtt: mqtt connection error: EOF”, how do i fix it?

look into all config files in the sections related to MQTT
P.S. is your mqtt broker running?

About those files, are you trying to say into de cfg of the servers and the gateway? This is a screen about the MQTT Broker. Is active and, apparently there is not an error into the MGTT Broker.

Well, what’s not clear? your gateway bridge cannot connect to mqtt broker
find out why it cannot.

As i have seen you didn’t put a frequency plan. Check your firewall settings on Ubuntu. How is your router connected to the internet? via ethernet or wifi?
Try to connect your gateway with cable to your router or check your router firewall settings, and let me know. good luck.

I have the correct frequency plan already (US915), in ubuntu all the required ports are set (pic below)

The gateway is connected via ethernet cable and the firewall in the router has all the ports allowed that my vm (pic below)

And the servers and the gateway brigde does not shows error msgs finally, what else can i do to solve this problem? (pic below)


This was the solution, in the fireewall i had the ports as shown in the past pic but in TCP protocol, not UDP.

1 Like

Hi friend i have a similar problem, what ports do you change to udp?