Help testing ChirpStack v4 (test releases)!

Yes, please see GitHub - chirpstack/chirpstack-v3-to-v4: Utility to migate ChirpStack v3 data into ChirpStack v4. :slight_smile:


Any estimation about the final release?

1 Like

I have a problem with http integrations but I am not sure if this is the correct way it should work.

I have setup an http endpoint and I am receiving posts from chirpstack 4 server but I can’t find the correct payload anywhere.

The data field contains some characters that seems to be base 64 encoded (not sure)
ex data: ‘AAAB/Q==’, data: ‘AAAB/QAAAAAAAAAA’

From WebUI on device events I can see the correct data (000001fd, 000001fd0000000000000000)

I’m currently working on V4.0.0-test2
Even after setting up my concentrator shield, I get the message
"chirpstack-concentratord failed to start (exit status 1)" - configuration file does not exist
I got back to the main menu (sudo gateway-config) and found out that the Concentratord config files are empty. Is this a known bug? Where should I create the config files manually?
(My hardware is RAK2246 - AU915 - channels 0-7)

Hey @orne I appreciate you are super busy, however, in terms of some forward planning, do you have sort of vague idea regarding the release date for v4?

I am battling with a number of devices a customer has thrown at me, and before I start writing all the custom codecs, I was wondering if it would simply be better to wait for v4?

I also have a Tier 1 Telco, stuck on a very outdated version, and this version release will hopefully get them to agree to do the upgrade…

I promise… I wont, hold you to any dates offered, I just need a rough idea, like 1 month away, 3 Months away, 6 months away… etc… Many thanks

PS… I really love the step change in the UI and cant wait to start throwing some more devices at it!

Thanks again for all your tireless work…

1 Like

Yes, I accidentally broke something in the gateway-config script (see Fix setting SUFFIX. · brocaar/chirpstack-gateway-os@19492d6 · GitHub). I will create a new GW OS test-build soon.

1 Like

I’m aiming for ~ 1 month :slight_smile: There are still some loose ends, but the major features are mostly implemented and I don’t expect to make any major changes to the API. Some features could be added after the first v4 release as well.

1 Like

@brocaar thanks for answering my first question. I managed to create the config files manually but now I’m stuck in another bug. My gateway uses pin 26 as GPIO7, I uncommented the proper line in the boot config file (/boot/config.txt) and it worked at first. Then, after some time (especially when I had to change my WiFi settings or had turn my RPi off for a while) it looked like the RPi ignored the pin configuration and the Concentratord stopped working (it restarts continously).
I double-checked my config file and made sure the line was uncommented, but it seems to have no effect anymore. Last time it happened, I had to flash my SD card again and redo all the gateway setup. Is there a “default boot settings” file that can be read instead of the one we edit normally?

I don’t think this is related to ChirpStack v4, lets not mix up different topics :slight_smile:

@orne you legend… thanks!

In the latest version you will also find a new “device metrics” feature:

With the payload decoded by the codec function in the device-profile, measurement keys are automatically detected and stored in the device-profile measurements configuration tab (or you can add them yourself). The only thing you then need to do is select the measurement-kind and to give it a user-defined name, such that ChirpStack can aggregate the data for you. If no measurement-kind is selected, this feature is disabled (default behavior).

The purpose is not to turn ChirpStack into a complete dashboard solution and beat tools like Grafana, ThingsBoard etc… The scope of this feature is to provide simple visualization to help with initial testing and POCs :slight_smile:


I’ve uploaded new test images:


This is looking great @orne! Awesome job. Whats the timeline for a final release?

it’s like you can read our minds This is awesome and exactly what we will use for PoC’s moving forward!

What about docker user.?? That is my docker setup…

That is gateway os not the stack in docker. latest tag I see is test7

HI @orne

I was just wondering how you configure a gateway to be in a different region.

Whilst we are in EU, we have a partner in New Zealand. We added the gateway, but the region still says EU. It is not apparent where to change the region?

Can you advise?


I managed to change the region, and I think I understand now. If one is to have multiple regions, do we simply need to create another gateway bridge and add it to the stack and then point the gateway at the associated bridge?

Is there a way to disable frame counter validation for ABP devices? Although this is not good practice, it would be great for development and debugging.

Any hint where to place uplink_dwell_time_400ms configuration in 4.0?

I tried to put it in the region toml but is not being picked and sent by chirpstack