Live Frame Issues and Gateway Configuration Issues


It has been a really long time since my last post. I recently picked up the efforts again to start an Open Source LoRaWAN network for my community. But I am faced with some troubles.

With the Server:

I completely setup a fresh server blade on Ubuntu 18.04 and did the usual sudo apt update && sudo apt upgrade followed by the steps highlight in each guide for Network Server and Application Server. Right out of the gate I am having issues in the Live LoRaWAN Frames section. I get the rapid flicker “Not Connected to WebSocket API”.

My Redis is currently

With the Gateway:

I have a Tektelic Kona Macro (actually I have 5) and I have updated it to the latest BSP after following the steps listed on the Tektelic Knowledge Base. I have also followed the guides from Chirpstack about uploading the .ipk file and installing it. I edited the config file to point @ with the ports set to 1700. Nothing is connecting. So I went to TTN and created an account and set up a Gateway following their guides and it worked. I did this to rule out the gateway not being able to connect or transmit. So there is something wrong in the configurations for sure. So I set things back to point at my Chirpstack Server and still nothing. I even followed a step suggested by what I think is an admin to opkg remove tektelic-mqtt. Still nothing.

Now then, I am asking for a little bit of help here. Keep in mind I am not expert at this but I have some working knowledge of the subject. I am just a dude who needs help, helping his community.


What are the chances this is an issue with my home network? I am setting this up in my house before I deploy the server to the rack at the university. I am getting desperate and starting to wonder if my network is blocking the gateway…

Never mind, I figured it out. Super thrilled with the support from this community. :no_mouth:

im facing the same issue and have the latest version of redis database
how you solved it cna u help