Looks like fake_gps doesn't put GW on the map

I’v got several gateways configured and working (with Lorix OS) and one with PI. But looks like even if I set fake_gps parameters it’s not get by application server.

{
  /* Put there parameters that are different for each gateway (eg. pointing one gateway to a test server while the others stay in production) */
  /* Settings defined in global_conf will be overwritten by those in local_conf */
  "gateway_conf": {

    /* You must pick a unique 64b number for each gateway (represented by an hex string) */
    "gateway_ID": "FCC23DFFFE0AA460",
    
    /* Gateway GPS coordinates */
    "fake_gps": true,       /* Only fake gps is supported, should stay to true */
    "ref_latitude": 46.566289, 
    "ref_longitude": 0.371997, 
    "ref_altitude": 10       
  }
}

Here the config on Lorix OS, as you see simulation mode is seen

image

And when packet received on GW, no location

Same thing on a raspberry Pi with IC880A, did I missed something ?

you are missed “gps”: true, in the local_conf

You beat me, though this one was relative to real GPS with serial port.

I put in the local_conf to be consistent, it worked immediately

thanks.

not only for this. without this option enabled gateway will not send the GPS information from any source.

Good to know thanks,

I think I tested too fast, the coordinates was the one I set up into the network application the 1st time I added the GW. So I deleted the GW from application server and created it back. it is seen but coordinates are still set to 0

I restarted the forwarder on GW of course.

Ok got some investigations here,

If I’m using GW with old legacy poly packet forwarder on 2 backends including TTN and our own chirpstack instance, it works.

if I’m doing with new packet multiplexer (so forwarder to local multiplexer and multiplexer forwarding to TTN and chirpstack) it does not work. May be the multiplexer is not forwarding the info packet?

@brocaar could you confirm or not?

I’m not sure but if you think this is a bug, then please create an issue for this: https://github.com/brocaar/chirpstack-packet-multiplexer/issues

@brocaar it’s a bug confirmed on the packet multiplexer running on the Lorix One, Christian will fix on next LorixOS release. Not sure the bug is existing on your version also.