LoRa Class A node OTAA - with most current LoRaMac code at Master on Github


Has anyone tried the current LoRaMac code at Master branch (on Github) on the LoRa Node and used that node successfully with LoRaServer?
The current version of this LoRaMac code is based on LoRaWan specifications 1.0.3 rev A.
If anyone has used this with their Class A OTAA node successfully with LoRaServer, would you please share your experience…


Are you having an issue, or are you trying to figure out if it is worth spending time trying?

I think I built that once last year, but efforts then were going in a different direction, may revisit it sometime. I do believe it gets a lot of use, mostly within the mbed environment (where it looks to be a bit of a turn-key import), and I had the unconfirmed sense it was what things like the ST eval board, and some of the various sensors straddling the line between products and eval boards are using.

There’s something of an umbrella thread on various node stacks on the TTN forum - LoRaServer isn’t on topic there of course, but behavior of nodes should be relatively common, to the degree that specs are complied with.

Hi @cstratton
Thank you so much for your reply and the reference post of TTN :slight_smile:
My node currently uses older version of LoRaMAC and I was planning to upgrade the code to the most current for sometime and putting it off. But that need to be done sooner or later, so why not now:) And since I am also planning to stay with using LoRaServer, need to test with LoRaServer.

I have recently tried the latest master branch build with the B-L072Z-LRWAN1 dev board Class A OTAA US915 region and it worked right away without any issues.

Did you tried to send a data from device to server?
My problem is described here:

I used STM32CubeExpansion_LRWAN_V1.2.3 set of libs, but seems to me it just a clone of LoRaMAC inside.

It is. ST wraps their LoRaWAN code around the Semtech/Stackforce LoRa MAC layer code. There are currently a few small differences between the two, mostly things like function names to get the current time from the RTC and such, but otherwise, 1.2.2 and 1.2.3 are the same as the develop branch.

Yes I have been sending data without any issues, except I’ve been using the Semtech LoRaMAC library directly. I haven’t experienced the issue you are seeing so unfortunately I don’t have a very good answer for you!

OK. Thanks.
Seems I found the source of my problem with sending payload.