Lora-gateway-bridge configuration file Isse

Hi all,

First of all @brocaar: thanks for the fantastic work and support for all the loraserver components.

I’m using the following setup right now:
Gateway: Wifx Lorix One
Lora-Gateway-Bridge: V3.2.1 (installed on the gateway)

MQTT-Broker is running on another host.

The connection from lora-gateway-bridge to the MQTT-Broker can be established as expected when starting the bridge manually:
with the command: ./lora-gateway-bridge -c /etc/default/lora-gateway-bridge

Now when i want to start the bridge trough the clouds-manager.sh (provided by Wifx), i get the following error messages
(see screenshot below). It does not recognize the terms inside the []-bracket. It interprets them as commands.

Now my Questions:

Many Thanks in advance for any help.

I would suspect the Wifx script clouds-manager.sh is starting the lora-gateway-bridge without the -c flag. As a result the lora-gateway-bridge cannot find the .toml configuration file. Without the -c flag it would be looking in the three standard file locations and not in your location of /etc/default/lora-gateway-bridge

A very quick way to prove if my theory is correct would be to copy the .toml file from /etc/default/lora-gateway-bridge and put in the same directory as the lora-gateway-bridge executable code.

Alternatively you could check and edit the clouds-manager.sh file.

@Tony: Thanks for you help.
The clouds-manager is configured as such that it starts the lora-gateway-bridge through the init-File (start the daemon). The configuration file is referenced there correctly. However when starting the lora-gateway-bridge through the init-file the interpretation errors (as in the screenshot above) occur.
When the lora-gateway-bridge is started from the command-line (using the same config-file) it works fine. it must be some sort of an interpretation issue from the lora-gateway-bridge init file.

Here some screenshots of the lora-gateway-bridge init file:

the starting command is not commented (with #). In the screenshots above it was just for testing purposes.

I’m not familiar with this method so don’t have any experience to share.

I would try copying the configuration file (.toml) to /opt/lora-gateway-bridge/

@Tony: I tried to move the config file to /opt/lora-gateway with the same result. Somehow when starting the lora-gateway-bridge through the daemon the config file can’t be interpreted correctly. Thanks anyway for your support, i appreciate it.

I found out that for some reason it works when leaving a space inside the square brackets of the topic. For instance [ general ] works whereas [general] gives the error: command not found, though only when running through the daemon.

This case can be closed. Thanks.