LoRa Gateway Bridge does not send data to MQTT broker



loraserver is not getting my data from gateway.

But Gateway sends data perfectly.please check the lora-gateway-bridge log

INFO[0252] gateway: received udp packet from gateway     addr="" protocol_version=2 type=PushData
INFO[0252] gateway: rxpk packet received                 addr="" data="gDQLbwOAEAAFpzXE2vZHQ74=" mac=b827ebfffec3XXXX
INFO[0252] gateway: sending udp packet to gateway        addr="" protocol_version=2 type=PushACK
INFO[0252] backend: publishing packet                    qos=0 topic=gateway/b827ebfffec3XXXX/rx

TCPDUMP result from gateway

.................%1..'......{"rxpk":[{"tmst":1121181515,"chan":2,"rfch":1,"freq":868.500000,"stat":1,"modu":"LORA ","datr":"SF7BW125","codr":"4/5","lsnr":7.2,"rssi":-106,"size":17,"data":"gDQLbwOAEAAFpzXE2vZHQ74="}]}
11:15:52.485779 IP localhost.1700 > localhost.44562: UDP, length 4

But when i check loraserver and lora-app-server log, there is no change in the screen


INFO[0000] backend/gateway: connected to mqtt server
INFO[0000] backend/gateway: subscribing to rx topic      qos=0 topic=gateway/+/rx
INFO[0000] backend/gateway: subscribing to stats topic   qos=0 topic=gateway/+/stats
INFO[0000] migrations applied                            count=0
INFO[0000] starting api server                           bind="" ca-cert= tls-cert= tls-key=
INFO[0000] starting downlink device-queue scheduler
INFO[0097] finished unary call with code OK              grpc.code=OK grpc.method=GetDevice grpc.service=ns.NetworkServerService grpc.start_time="2018-08-21T11:25:18+05:30" grpc.time_ms=0.646 peer.address="" span.kind=server system=grpc
INFO[0099] finished unary call with code OK              grpc.code=OK grpc.method=GetDeviceProfile grpc.service=ns.NetworkServerService grpc.start_time="2018-08-21T11:25:20+05:30" grpc.time_ms=0.751 peer.address="" span.kind=server system=grpc
INFO[0102] finished unary call with code OK              grpc.code=OK grpc.method=GetGateway grpc.service=ns.NetworkServerService grpc.start_time="2018-08-21T11:25:23+05:30" grpc.time_ms=2.783 peer.address="" span.kind=server system=grpc
INFO[0108] backend/gateway: publishing tx packet         qos=0 topic=gateway/b827ebfffecXXXX /tx
INFO[0108] finished unary call with code OK              grpc.code=OK grpc.method=SendProprietaryPayload grpc.service=ns.NetworkServerService grpc.start_time="2018-08-21T11:25:29+05:30" grpc.time_ms=1.139 peer.address="" span.kind=server system=grpc


INFO[0094] finished client streaming call                grpc.code=OK grpc.method=StreamFrameLogsForGateway grpc.service=ns.NetworkServerService grpc.time_ms=0.02 span.kind=client system=grpc
INFO[0094] finished unary call with code OK              grpc.code=OK grpc.method=Get grpc.service=api.OrganizationService grpc.start_time="2018-08-21T11:25:24+05:30" grpc.time_ms=3.13 peer.address="" span.kind=server system=grpc
INFO[0099] gateway ping created                          dr=0 frequency=86800000 gateway_mac=b827ebfffecXXXX id=429
INFO[0099] finished client unary call                    grpc.code=OK grpc.method=SendProprietaryPayload grpc.service=ns.NetworkServerService grpc.time_ms=1.78 span.kind=client system=grpc
INFO[0099] gateway ping sent to network-server           gateway_mac=b827ebfffecXXXX id=429
INFO[0099] gateway updated                               mac=b827ebfffecXXXX name=XX-LoRa-Gateway

It clearly shows that, data is out from gateway,
Even i tried subscribing to mqtt topics from server side,but still no response for mqtt topics also.
Please help me to resolve this!

To summarize, your gateway communicates correctly with LoRa Gateway Bridge and LoRa Gateway Bridge is forwarding the data to the MQTT broker without any errors.

Then when subscribing to the gateway/# mqtt topic, you don’t see any data?

That looks like a MQTT ACL issue to me. E.g. the connected MQTT client does not have permissions to subscribe to these topics?


Thanks for your reply. :slight_smile:
It was working fine for few weeks,i haven’t done any changes on the mqtt acl part. :wink:
Can you please suggest me for the next move ?

Find out what did change between when all as working and now :slight_smile:

Thanks @brocaar. I will check and get back to you.


Issue is resolved.

What i have done is ,installed lora-gateway bridge on my server itself, instead of gateway .Now everything works fine.

I am not sure whether this is an correct approach or not? :slight_smile:

Your thoughts on this ?

Given that it works on one box and not the other, it seems like a network related issue to me.


Thanks Brocaar! For Your Support :slight_smile: