Passive Roaming (v4 Help)

Apparently the certs are correct, but chirp is reporting tls error during handshake.

Is there anyway this can be tested by someone that knows more about this?

I tried mapping the letsencrypt certs, but it also still throws the same error. what are the names of the letsencrypt certs you are mapping so i can double check iā€™m mapping the right ones.

Either way i cant seem to get past this error no matter what certs i used at the moment and making the logs show debug doesnt give me any futher verbosity on the issue.

2023-11-08T00:43:29.743971Z  INFO up{deduplication_id=7750ba1d-5146-435e-a2af-5c782f116d5a}:data_up:data_pr: chirpstack::uplink::data_fns: Starting passive-roaming session net_id=000013 dev_addr=260d8135
2023-11-08T00:43:59.838479Z ERROR up{deduplication_id=7750ba1d-5146-435e-a2af-5c782f116d5a}:data_up:data_pr: chirpstack::uplink::data_fns: Start passive-roaming error net_id=000013 error=channel closed

this was my last correspondence with ttn. so i really have no idea how to further debug this. if anyone has any idea please lmk.

The certs look good now, but curl still fails and Packet Broker shows:

roaming: request failed: Post \"https://example.com:5138\": remote error: tls: handshake failure

"remote error" indicates that the server (ChirpStack) gave an error during the TLS handshake.

Nothing we can diagnose further from our side, unfortunately.

Hi @ccall48
Did you manage to get it working? Talking to Johan now to see if they see anything on their end but I guess we are facing the same problem you did.

Unfortunately not yet. nothing I have tried seems to work, I spent a few weeks on this too =/

If you have any wins please let me know!

1 Like