Problem when trying to setup an environment (chirpstack-application-server)

Hello everybody.

I’m trying to setup an environment to customize the UI, however, I’m new to the docker … and when running the docker-compose up it logs this:

Building with native build. Learn about native build in Compose here: https://docs.docker.com/go/compose-native-build/
Starting chirpstack-application-server-master_mosquitto_1 ... done
Starting chirpstack-application-server-master_rabbitmq_1  ... done
Starting chirpstack-application-server-master_zookeeper_1 ... done
Starting chirpstack-application-server-master_postgres_1  ... done
Starting chirpstack-application-server-master_redis_1     ... done
Starting chirpstack-application-server-master_kafka_1     ... done
Starting chirpstack-application-server-master_chirpstack-application-server_1 ... done

docker-compose ps (apparently no error):

chirpstack-application-server-master_chirpstack-application-server_1   /bin/sh                          Exit 0                                                                
chirpstack-application-server-master_kafka_1                           /opt/bitnami/scripts/kafka ...   Up       9092/tcp                                                     
chirpstack-application-server-master_mosquitto_1                       /docker-entrypoint.sh /usr ...   Up       1883/tcp                                                     
chirpstack-application-server-master_postgres_1                        docker-entrypoint.sh postgres    Up       5432/tcp                                                     
chirpstack-application-server-master_rabbitmq_1                        docker-entrypoint.sh rabbi ...   Up       15691/tcp, 15692/tcp, 25672/tcp, 4369/tcp, 5671/tcp, 5672/tcp
chirpstack-application-server-master_redis_1                           docker-entrypoint.sh redis ...   Up       6379/tcp                                                     
chirpstack-application-server-master_zookeeper_1                       /opt/bitnami/scripts/zooke ...   Up       2181/tcp, 2888/tcp, 3888/tcp, 8080/tcp    

But, when running npm start on ./ui it returns this error on requests:

Proxy error: Could not proxy request /swagger/internal.swagger.json from localhost:3000 to http://localhost:8080/.
See https://nodejs.org/api/errors.html#errors_common_system_errors for more information (ECONNREFUSED).

Thanks.