Problems activating Elsys ERS CO2 Lite

I have installed the application and network servers as per the manual and there seems to be data going through from my Mikrotik KNOT LR8 gateway. When I subscribe to the MQTT gateway-topic on the server, I can see messages from the gateway. They look encoded, but that should be OK? So, my understanding is that there is a proper connection alive between the gateway and Chirpstack.

EDIT: I am not getting any data in the LIVE LORAWAN FRAMES tab, so maybe my assumption is not correct? I have not made any adjustments in the gateway-bridge setup.

Now for the device. We have an Elsys ERS CO2 Lite sensor in the office that we would like to connect to Chirpstack using OTAA. When I use Winbox on the Mikrotik gateway, I can see that the Elsys-sensors sends Join-Request messages to the gateway. My understanding is that Chirpstack is then supposed to register the Elsys sensor Join-request based on the configuration of that sensor, then send a response back to the sensor with the proper configurations?

On Chirpstack I have tried to setup the configurations that I have info on.

The device has the proper DevEUI - I’ve checked about 10 times. It also has the proper AppKey, which I also checked 10 times. That part seems straightforward.

The Device Profile is a lot more confusing. I’ve tried all possible variations of the variables, but honestly I’m not sure any of them have been correct, but I can’t find any documentation on the specs for the Elsys ERS CO2 Lite. Here is my current setup, which is probably wrong (finding the right documentation on this is a lot harder than I expected):

LoRaWAN MAC version: 1.0.2
LoRaWAN Regional Parameters revision: RP002-1.0.3
ADR algorithm: Default ADR algorithm (LoRa only)
Max EIRP: 0
Uplink interval (seconds): 600 (I know this is correct, since the sensor sends data every 10 minutes

Device supports OTAA: true

Device supports Class-B: not set

Device supports Class-C: not set

Codec: not set (I’m thinking that’s something to do after the sensor is actaully connected?)

Has anyone had success in setting up an Elsys ERS sensor? If so, I would very much like to hear from you


Which version of Chirpstack have you installed?

Is your gateway marked as “Last seen” within a couple of seconds ago within Chirpstack?

The Elsys devices are pretty well documented from what I recall. Additionally all the codecs are available in CS4 (if you have imported the TTN repo) so this should all be around a 5 min job to add a device as long as your setup is good.

1 Like

I was actually just about to update my post. There was nothing wrong with Chirpstack or the Elsys sensor.

I installed Chripstack on a server that had an existing Redis installation. In the config of Redis I had defined aliasses for the commands for security reasons, per the recommendations of the installation guide I followed back then. Turns out, Chirpstack can’t use Redis properly when those command aliasses are defined. So I removed them an everything works perfectly now.

However, I think the Redis guide recommended those aliasses for a reason, so I was wondering if there is a way to make Chirpstack use Redis command aliasses, but that’s for another topic I guess.