Realization of multicast does not work

Hey all,
I am trying to realize multicast for X nodes: Currently, all nodes start in class A and they are switching in class C after a multicast-message was received.

I am working with two version of the LoRa-Gateway-Bridge (LGWB), LoRaserver (LNS) and LoRa-App-Server (LAS) at different locations.
At the first location I am working with the current release:
LGWB v2.4.1
LNS v1.0.0
LAS v1.0.2

At the second locations the versions are:
LGWB v2.1.5
LNS v0.19.2
LAS v0.10.1

Now, my problem is that my multicast procedure is working fine at location two but not at one: after changing in class C, the nodes are not receiving any downlink messages but I can see that there is downlink received by the application-server in the “Live LoRaWAN frame logs” of my “multicast node”.
I configured two “Device profiles”: one for class A nodes and the other for class C and I checked the keys. The uplink works in class C mode as good as in class A but not the downlink. I hope it is a misconfiguration of the application-server because the code works at location two.

Hope there is someone who can help me.

Thank you and best regards,


Muticast isn’t (properly) supported yet.

Hey brocaar,

yes I know, but I found a post where you recommend to create two profiles (one for class A and one for C, both ABP). Now, class A nodes shall switch to class C profile during runtime
I tried it and it works for the mentoined versions but not for the current release.

It could be because of mac-commands send during downlink. For testing you could disable the mac-commands completely. In loraserver.toml:

  # Disable mac-commands
  # When set, uplink mac-commands are ignored and the network-server will not
  # send mac-commands to the devices. This is intended for testing only.

Thanks for your help.
Fixed it!

Is this still true?

What is current state of multicast?