Redis error after GatewayOS reboot

Hi all, am running the full gatewayOS on a LorixOne. Its been working good for a whole day, until this morning when I powered it down to re locate it outside. Now when I powered it back up and go in the web UI to view gateway I get a Redis connection error. Also if I start loraserver at the CLI, the full error is as follows:

ERRO[0074] gateway/mqtt: acquire stats lock error: redis connection error: dial tcp [::1]:6379: connect: connection refused

Nothing had changed. If I manually start Redis with sudo redis-server I can appear to browse the web UI without an error. Although no comms from devices showing.

What is going on here?

If a simple loss of power kills this. There is no use for the full gatewayOS build at all.


Did you ever find a resolution to this?

I am currently using a RAK2245 with the full gatewayOS, and I had things working fine this morning. However I noticed that the time on my Pi was reporting that it was behind by 3 days, I changed the time and rebooted and ever since then I run into the same problem you have. If I click Gateways in the Application Server I get “redis connection error: dial tcp [::1]:6379: connect: connection refused (code: 2)”

Like you if I run sudo redis-server on the device then things seem to be working, but if I reboot then I have to restart the redis-server. On my initial install I did not have to do this and during this time I even rebooted multiple times.


Hi, I just found this thread after publishing a similar error report in the ChirpStack Gateway OS forum.

As stated, above, this error makes the gateway unusable ( i have a one-hour drive to this gateway and not so happy project partners right now since everything is down in a ag tech research project that can only be done these week due to winter climate… )

I will report it on the github repo…

Seems there is an append only file error somewhere…

I think I have a fix, but it requires a change to the startup scripts, see

1 Like