RN2903 channels being re-enabled

I’m having a problem with enabling/disabling channels on the 2903. Initially I disable all the channels, then re-enable channels 8-15 (corresponding to the channels enabled on the Laird gateway). All this has been working, until I enabled ADR.

Now, immediately after config, chans 0-7 are off, but after the first downlink from the server, chans 0-7 are turned on.

I have chans 8-15 in the gateway-profiles, and factory-preset frequencies 903.9MHz to 905.3MHz in the device-profile.

Any idea why chans 0-7 are being re-enabled?

Apologies if this was handled in another topic.

It appears that editing the .toml file to specify the channels and rebooting fixes the problem, while making the changes only in the portal doesn’t.

I haven’t confirmed this yet, but editing the .toml file directly did appear to fix the channel problem.

It also appears that changes in the portal aren’t written to the .toml file?