RX after uplink doesn't consume downlink message

Hi.

As response of an uplink message, I send informations to the node.
The node opens fine its RX window a couple of seconds after the uplink end.
When the node opens the RX window, I have the message in the downlink queue.
The network server doesn’t send the message to the node.

I tried to solve it by putting a long time between uplink and rx1
I also tried to activate rx2 window.

To permit the downlink message to reach the node, I must do another uplink message a couple of seconds after the first uplink.
Is it normal? I thought that the rx window was made to receive answer to uplink message. Isn’t it the case?
If yes, do you have an idea?
Thanks a lot for your help.

Solved.

It’s dued to get_downlink_data_delay parameter.
By default, get_downlink_data_delay=“100ms”
My application server needs about 250ms to process the answer, more than 100ms
I changed to :
get_downlink_data_delay=“750ms”
rx1_delay=1

and it works fine.

You might want to increase rx1_delay to 2 to be on the safe side. Increasing the get_downlink_data_delay means that you have less margin between the NS and the GW, so depending your setup you could see an increase in downlinks being rejected because they arrived too late at the gateway to be transmitted.