Sending uplink messages on Queue

I use the latest version of the Chirpstack server on a Docker on AWS ubuntu micro version(the lightest version of ubuntu possible on the cloud), together with a LORIX One device and 2 GPS trackers from Antratek Browan.

I’m calling you because I encountered a problem related to sending setting/configuration messages to these 2 devices. When the Chirpstack server was running on my PC, the messages were sent instantly after receiving a message from the device I wanted to configure. After I moved everything to AWS, the messages remain in the queue, and the pending always remains on NO.

Following some questions related to this one,I managed to lower 2 values from chirpstack config:
down to 50ms and up to 1000ms, but nothing happened.

Plus, when I ran the entire architecture on an Ubuntu machine from AWS, but this time medium (2 CPU and 4 Gb RAM), it worked.
Do you have some ideas about what changes I can do to run this config on a micro VM (1CPU and 1 Gb RAM)?

Thank you!

Can add 4GB swap for it.
T2.micro can run ChirpStack v4 fine.

@datnus do you know what is the culprit that causes this?

My t2.micro + 4GB Swap works perfect.
I never try t2.micro alone. Guess not enough memory.

Why do you think that memory has anything to do with the issue?

I think the key here is some delay toleration configs and not the actual Ram usage.
When the memory is not enough the kernel will just kill the process.

The poster did mention more RAM in his instance fixed his issue.

You can propose your solution btw. Good to know more alternative solutions.

We are working both on this and haven’t found a solution hence the post here in the forums :slight_smile: