Validate dev-nonce error

Hi @NULL1
clear dev-nonce button on Activation Tab

Go to device details page → Go to Activation Tab → Clear DevNonce Button

Is there a way to read the last dev nonce value for selected device? Preferably from postgres console without pgAdmin (database accessible from localhost only)?

Reason is that I had two devices out of gateway’s reach for almost a month, so I would like to check how the devices firmware handled that situation.

Never noticed there is a button to do that :sweat_smile:
Thank you

1 Like

Ok, found it:

# Connect to postgre terminal:
sudo -u postgres psql

In postgre terminal:

-- Connect to network server database (v3):
\c chirpstack_ns
-- List records for DevEUI = 0123456789abcdef:
SELECT * FROM device_activation WHERE id IN (SELECT id from device_activation WHERE dev_eui = '\x0123456789abcdef' ORDER BY id DESC) ORDER BY created_at DESC;
-- Or list all records:
SELECT * FROM device_activation ORDER BY created_at DESC;
-- Quit postgres:
\q

Hi,
I had the same issue with “Validate dev-nonce error”. Clearing the database with both web-interface and with SQL command did not solved it.

  1. Devices with APPEUI : 0000000000000000 - join was succeeded.
  2. The Error came up with device with APPEUI which is not 0000000000000000. i could not config the APPEUI at this device to 0000000000000000. allowed values are 0000000000000001 -FFFFFFFFFFFF .

After downgrading to following versions :
chirp-application-server 3.17.3
chirp-network-server 3.15.3
chirp-gateway-bridge 3.13.1

JOIN was succeeded and there was no “Validate dev-nonce error”.

Hi,

I turned off my gateway for a few days, when i turned it on, every end node sucessfully join the server except the one that was having problems 2 months ago. Its a LT-22222-L, class C etc, and already worked for a few days.
Soo, join request after join request, already cleared DevNonce from Web Interface and manually from database. At “Device Data” field, nothing is shown, so I really don’t know what error is.
Anyone can help me? I’m getting very frustrated with this end node, all of them worked for the past 4 months without any error.

Reboot the end node to rejoin.

Hi datnus,

Thanks for your help.
I already rebooted the end node and gateway several times and still the same.
Any other suggestion?

Thanks.