Adding Dragino LWL02 Waterleak Sensor


i’m using a wisgate rak 7268 v1. I have successfully connected it to my ubuntu/docker container remotly with chirpstack. It shows online.

Now i wanted to setup a test device. A Dragino LWL02 Waterleak Sensor.

Therefore i used to setup a device profile with 868mhz, Lorawan 1.0.3, Regional Parameter A, Default AGR algorithm, otaa activated, Codec Cayenne. On device i set the device eui, In configuration variables i set a app_eui (don’t know exactly if i have to), And otaa keys the AppKey.

I can see that the device sends data on my gateway:

    "freq": 868100000,
    "chan": 5,
    "tmst": 951653573,
    "utmst": 1708029479183,
    "rfch": 1,
    "stat": 1,
    "rssi": -75,
    "size": 23,
    "modu": "LORA",
    "datr": "SF7BW125",
    "codr": "4/5",
    "lsnr": 13.8,
    "MHDR": {
        "MType": "Join Request",
        "RFU": 0,
        "Major": 0
    "JoinRequest": {
        "AppEUI": "A8 40 41 00 00 00 XX XX ",
        "DevEUI": "A8 40 41 83 41 86 XX XX ",
        "DevNonce": "26XX"
    "MIC": "8565ECXX"

And on logs from docker i can see the following:

So, i don’t know what else to do, maybe someone can help. thx

Same Problem with Milesight M300. I have to mention, that i have nothing special configured in chirpstack i directly used docker compose.

Solved - My problem was my gateway (v1) does not support chirpstack v4. The Gateway becomes online but device join was not possible with mqtt chirpstack forwarder. Therefore i now switch so semtech udp and port 1700 and now it works.

1 Like