ADR not working when a gateway is connected by 3G (high latency)

Hello Orne,

I have a Lorank8 connected with 3G to the LoraServer / LoraAppServer running on a cloud server. The node I use is a Microchip LoRaMote running a slightly modified software. Probably due to the big latency (delay) of the 3G connection, ADR is not working. I haven’t tried downlinks, but most probably they won’t work well either. OTAA works, due to its “tolerance” for big latency. If I change the connection to cable Internet, everything works well. I am aware that the latency of the 3G connection is very big because when I connect another gateway through 3G (or even cable Internet), I have to set the de-duplication delay to a very big value (700-900 ms).

What is your suggestion, what parameters should be changed at LoraServer and to what values? Or should I change the parameters at the node itself?

Thanks for your response!

You could set this parameter (

--rx1-delay value                       class a rx1 delay (default: 1) [$RX1_DELAY]

E.g. setting it to 5 (seconds) would give you the same delay as with OTAA :slight_smile: Don’t forget to re-activate your node (OTAA) as the delay is given to the device as part of the join-accept message.

Thanks, I will try it tomorrow.