Application server dashboard does not get updated

Hello everyone,

I have added a gateway, a sensor device. In the gateway seems that i can get live lorawan frames as you can see below :

But my dashboard is always like that and the devices(both gateway and sensor) are in the status “never seen”.

Any ideas what is going on?(i am using docker build & some months ago it was working perfectly)

Docker logs error : time=“2022-08-30T18:48:18.409244111Z” level=error msg=“gateway: handle gateway stats error” ctx_id=0baae**-828b-46ec-****-f61efe5f28de error=“handle gateway stats error: rpc error: code = Unimplemented desc = unknown service as.ApplicationServerService”

It looks like you have a configuration issue. The NS tries to forward the gateway stats to the AS, but the configured endpoint does not expose the as.ApplicationServerService gRPC service. Please check this part of the ChirpStack Application Server:

  # Public ip:port of the application-server API.
  # This is used by ChirpStack Network Server to connect to ChirpStack Application Server. When running
  # ChirpStack Application Server on a different host than ChirpStack Network Server, make sure to set
  # this to the host:ip on which ChirpStack Network Server can reach ChirpStack Application Server.
  # The port must be equal to the port configured by the 'bind' flag
  # above.

Then restart the ChirpStack Application Server and make sure to save the Network Server record in the web-interface.

If you have the opportunity, you can also try out ChirpStack v4 which simplifies the setup as the AS and NS parts are no longer separated.

Thank you very much for the reply!
Yesterday i tried the Chirpstack v4 but when i built it i cannot manage to get the application server interface.
Like there is no docker container for that.
Could you please share me the correct repo for the chirpstack v4 so i can clone it?

Also i am building the docker compose in a VM with a public ip… what should i put to the public_host?
this is my conf for application server:

Thanks in advance!

Hello Ivan!

The issue you are having have just happened to me a couple of weeks ago. As far as Brocaar suggests, it seems to me that the NS is not being able to report status correctly to the AS.

In Public host configuration you should write “chirpstack-application-server:8001”.

I left here a screenshot of my Chirpstack-application-server.toml file, just in case it helps you.



Hello Nicolas,
Thank you for your answer.
I dont know what is going on. I changed it as you proposed but i have the same error.
I have tried almost everything :stuck_out_tongue: but nothing works while some months ago everything was working perfectly.
If you have any other suggestions please give me your lights!!

It may be obvious but have you checked the Network-Server is in correct band?
You should enter your Network Server and see: “Name (EU868 @)”

In case it is not happening go to your Network Server Toml file and change band name.
In case it is wrong, this should explain your devices and gateways are “never seen”.

On the other hand, I dont know which gateway you are using, but you should also configure it to work in the band and subband prefeered. (In my case I use Dragino LG308 and access to his graphical interface just by putting it’s IP address on the browser, then configure band and subbands).

Yes, my NS is in correct band and i can receive data from the gateway(MikroTik).

Something is going wrong with the application server.
But how is it possible to see the live lorawan frames and the gateway is in the status “Never seen”?

Yes, I agree. It is a little contradictory the fact that your gateway receive messages but still is not seen.

Have you already tried to stop and restart your server? (If you make any change to any toml file, but do not do this, the changes do not apply!)

I would try to open command line and then:

cd chirpstack-docker
sudo docker-compose stop
sudo docker-compose up -d
sudo docker-compose restart

Yes, of course i did it.
It is the 10000000 time that i am using docker :stuck_out_tongue:
May you share with me the repo that you are cloning from to get the whole staff(docker-compose, config files etc?) just to make a new try. just in case something wrong in the repo i am using


The repo I used is the following “

Try using “git clone” command as you may know, then using docker-compose up should work.

(I’m taking for granted you already have installed Chirpstack gateway bridge on the gateway itself [in case it is necessary, for some gateways it is not], and that you have Netwotk server, app server, and gateway bridge in the VM you have created).

I don’t think that it is necessary for my gateway…As i mentioned before all this system was working perfectly some months ago.
I have already cloned from this repo, but i cannot access the application server interface with that. It is like there is not application-server docker container.I will give another try.!
But anyway thank you so much for your help!

1 Like

I changed the configuration file as Nicolas proposed then start & restart the docker compose.
Save & resave the network server in the UI and it worked.
I think you can close the issue.


1 Like