Backend interfaces API is disabled

Hello, in the company I work for, we recently started trying to implement ChirpStack 4.0. We followed the configuration documentations regarding Configuration, Debian/Ubuntu and Gateway Bridge Configuration found at:
https://www.chirpstack.io/docs/chirpstack-gateway-bridge/configuration.html

We tried running the server after the configuration was completed and we are getting a warning message 2022-11-04T09:35:39.841059Z WARN chirpstack::api::backend: Backend interfaces API is disabled. Given that this was a warning we decided to ignore it temporarily and attempted to access the GUI and run some tests.

Unfortunately, after adding a gateway to the server, we found that the gateway is not communicating (i.e. it was appearing as Never seen). Let me note here, that the same gateway was in our old ChirpStack instance (v3.8 if I remember correctly) and was fully operational.

Our configuration files are more or less in the default states, we are running on Ubuntu 22.04. I can link the configuration files if needed.

Please advise on how to proceed with a fix, because we need this for our R&D team.

Thanks in advance,
Malgorik

This is not related to the “Backend interfaces API is disabled” warning.

Things to check:

  • Are you using the latest ChirpStack Gateway Bridge v3 (which adds support for v4) or v4 version?
  • Does the MQTT topics match the ChirpStack v4 configuration (e.g. instead of gateway/.... did you change them to eu868/gateway/....)

Thanks for the prompt reply.

Your suggestion about the MQTT topics did solve the issue. We can now see the gateway online on the server.

However, even though our sensor now successfully joins the network, when transmitting confirmed uplinks, the sensor does not receive the ACK back from the server.

Hey @brocaar, I think I have the same issue even though I modified the topic configuration.

My MQTT integration configuration in chirpstack-gateway-bridge.toml :

event_topic_template="eu868/gateway/{{ .GatewayID }}/event/{{ .EventType }}"
state_topic_template="eu868/gateway/{{ .GatewayID }}/state/{{ .StateType }}"
command_topic_template="eu868/gateway/{{ .GatewayID }}/command/#"

I think that my chirpstack keep suscribing to the us915 topic

Here is a part of the log I get when I run my docker compose:

chirpstack-docker-chirpstack-1                       | 2022-11-11T17:35:55.679650Z  INFO chirpstack::storage: Setting up PostgreSQL connection pool
chirpstack-docker-chirpstack-1                       | 2022-11-11T17:35:55.679695Z  INFO chirpstack::gateway::backend::mqtt: Starting MQTT consumer loop
chirpstack-docker-chirpstack-1                       | 2022-11-11T17:35:55.679731Z  INFO chirpstack::gateway::backend::mqtt: Subscribing to gateway event topic region_name=us915_1 event_topic=us915_1/gateway/+/event/+
chirpstack-docker-chirpstack-1                       | 2022-11-11T17:35:55.726427Z  INFO chirpstack::storage: Applying schema migrations
chirpstack-docker-chirpstack-1                       | 2022-11-11T17:35:55.729734Z  INFO chirpstack::storage: Setting up Redis client
chirpstack-docker-chirpstack-1                       | 2022-11-11T17:35:55.851701Z  INFO chirpstack::downlink: Setting up Class-B/C scheduler loop
chirpstack-docker-chirpstack-1                       | 2022-11-11T17:35:55.851762Z  INFO chirpstack::downlink: Setting up multicast scheduler loop
chirpstack-docker-chirpstack-1                       | 2022-11-11T17:35:55.851771Z  INFO chirpstack::api: Setting up API interface bind="0.0.0.0:8080"
chirpstack-docker-chirpstack-1                       | 2022-11-11T17:35:55.851926Z  WARN chirpstack::api::backend: Backend interfaces API is disabled

Thanks in advance !

Please check the enabled_regions, maybe you didn’t enable the eu688 region?

I did enable the eu868 region.

Here is my chirpstack-gateway-bridge.toml file, maybe you can check it out and give us a feedback.
It would be very kind.

https://pastebin.com/yjursLq2

Thanks in advance !

That is the chirpstack-gateway-bridge.toml configuration file, please take a look at the chirpstack.toml configuration file (usually found in /etc/chirpstack/chirpstack.toml).