Can't add more devics to my platform

Hi team.

I’ve setted already several devices in my chirpstack platform all distribuited by different applications and they had been working very well.

Today I tried to add a couple more of devices, this ones are Lansitec devices for temperature measurements, but for some reason, the last ones I’ve added are generating an error message when I take a look into the “Device data” tab which says the next:

join-server returned error: response error, code: MICFailed, description: invalid mic

I’ve been reading in other posts that it might be related to the MSB and LSB bit order, so I tried changing this for some of the devices in the appkey and in the deveui but nothing happened, also I tried adding the devices in several of my different applications.

If you need further information to help to notice the problem, please let me know.

Regards.

1 Like

The join-request MIC is generated using the root key. Thus the error you are seeing is related to a mismatch in the key configured on the device and the ChirpStack Application Server (join-server interface).

Well, Actually I’ve tried adding 5 more devices and I keep having the same error, I don’t think so that it could be because of a mismatch or even a misstype because we can’t change those values for our Lansitec devices, also I usually do copy/paste from my own database to chirpsack platform for this values since I have clear that I can have misstyping errors.

So I’m worried it could be something about my chirpstack settings or any other kind of mayor issue

1 Like

Could it be that you have selected the wrong MAC version in that case (in the device-profile)? Note that the MIC calculation is different between 1.0.x and 1.1.x devices.

Hi Brocaar.

Thanks for your answer, but actually I’M using a single Device profile which has been working proprely with my devices, this isue I’m actually having just started to happen suddenly. I also tested deleting and adding the devices which were working and they keep working, it is just happening with the devices that I’m adding and that never have been in my platform before.