Can't install python chirpstack.api on ssh into Debain, stuck building grpcio

I recently have chirpstack running completely fine but wanted to send data from a single board pc running Debian Buster to a device using the python chirpstack.api. But when I to run (as root) the cmd:

pip3 install chirpstack.api

It downloads all the files and then starts running the bdlist for grpcio and gets stuck.
Eventually my ssh connection times out, so I thought it was a matter of changing the ssh_config file to set the ServerAliveInterval and ServerAliveCountMax. No matter how long it still just wont finish running the file. Then I tried just running the cmd: pip3 install grpcio, and same exact result at end of previous cmd.


I then tried installing the chirpstack.api on a pc that I didn’t ssh into and it installed just fine.
So, I guess my question is, can you not install it when you ssh into a pc? Or is there something else I’m missing? Please let me know if anyone know what might be the issue. Thanks

UPDATE: I found out that someone before me had set a RunTimeWatchDog var to check every 20 secs. This is what was stopping my installation from completeing because it would reset the single board computer after 20 secs. I changed that WatchDog var at /etc/systemd/system.conf so it was set to 0 instead of 20 and it installed fine. Hope this maybe helps someone else if they were in simular situation as I was.