Change ports 8000 and 8001

Hi @brocaar,
I was looking to find a way to change the port 8000 used by the lora-app-server to listen the loraserver.
And to change the port 8001 used by the loraserver to listen the lora-app-server.
I’ve got other apps on my machine, which used those ports.

I have got your sources and after a quick look, it seem that changing the ports will take some times.
i konw that in the config files you can change the ports but not for the listenner.

Thanks :slight_smile:

To change the port for the listener, you need to change this section in the loraserver.toml file:

  # Network-server API
  # This is the network-server API that is used by LoRa App Server or other
  # custom components interacting with LoRa Server.
  # ip:port to bind the api server

The same applies for other bind config options in loraserver.toml and lora-app-server.toml. Please note that when adding the network-server in the LoRa App Server web-interface, the port number must match. E.g. when changing -->, you must enter localhost:9000 for the network-server in the web-interface (given that both LoRa Server and LoRa App Server are running on the same machine).

OK for the port 8000, but for the 8001 (internal api) on the side of the loraserver, there is no wy to change this port.

I can change it on the lora-app-server side but not for the loraserve. :confused:


You need to change the (lora-app-server.toml):

  # Public ip:port of the application-server API.
  # This is used by LoRa Server to connect to LoRa App Server. When running
  # LoRa App Server on a different host than LoRa Server, make sure to set
  # this to the host:ip on which LoRa Server can reach LoRa App Server.
  # The port must be equal to the port configured by the 'bind' flag
  # above.

to how LoRa Server can resolve the LoRa App Server API interface. E.g. when the LoRa App Server API is listening on 9001 you set this to localhost:9001. When associating the network-server (in the web-interface), LoRa App Server will create a routing profile with that host:port combination.

Ok thanks, i’m just stupid i think…

I’m im the same boat, tried to changed ports like this:





Also changed updated Netkwork Server port in the web app to 9000. But whet tried to see live packets, there is no such, but a message showing something like “unable to connect to websocket api”

There is another missing file where port config must be changed too?


1 Like

Some test, changing only


And of course updating the network server port in the web app, behaves strange. Works partially! The node can join the server via OTAA, but the downlink responses for confirmed uplinks never sent nor enqueued.

Loraserver works very well with the default ports in loraserver.toml and lora-app-server.toml, but if something changed not.

I’m integrating loraserver with AWS greengrass core (that uses port 8000) so at this point i can’t make the two things work together.

Any help or light will be appreciated!

@brocaar am I able to do the same with application_server_external_api bind: Can I change it to port 80?