Chirpstack Docker compose not running

Hello Community,
I followed the steps mentioned for docker compose and unfortunately, I am not able to reach ‘http://localhost:8080/’. Please let me know if there were any steps i missed. I just cloned the directory and did docker-compose up.
Thanks in advance,

Please note that without providing any information we are not able to help you. All I can say, when I do a docker-compose up, it works for me, but that is not helpful for you either :wink:

Apologies for the vague question. Here are the steps i followed:

  1. Git Clone as mentioned in the tutorial file at github.
  2. Changed configuration file in Network and Application servers and set dsn to postgres://chirpstack_as:dbpassword@localhost/chirpstack_as?sslmode=disable and accordingly for the network server as well.
  3. docker compose -up. My docker.yml has all the default services from the git repo. Nothing changed.

My problem here is that even after a while, localhost:8080, i.e the application server is not started, and while debugging, i also found that when i do service mosquitto status, i get

Here are the docker compose logs:

Hope I am more clear this time. Thanks for your time.

check your postgresql and their prefs.

1 Like

@sanjeev_prasad the Docker Compose repo comes with all values pre-configured. There is no need to change any configuration, other than changing the region from EU868 to something else if you want to use a different region. It will also create all databases for you, see, these scripts are automatically executed at the first docker-compose up

Thank you for response @brocaar. I did the configuration change only because the default didn’t work. i see the ports for services mentioned in the yml being referred as ‘proxy server’ in my machine. I tried adding ‘network: host’, but in that case chirpstack servers did not bind to ports on my machine. I think this problem is specific to me and I need to debug further. Thank you for your help.

An update. All my problems were solved when I reinstalled the docker and cleared browser cache. Thank you guys. sorry for the confusion.