Chirpstack http integration not working

Does the http integration not work to https URL’s? The error I’m seeing is very vague so I’m not sure why it’s failing.

2024-07-02T15:16:19.140056Z WARN chirpstack::integration::http: Posting event failed event=up url=https://redacted:28088/services/collector/raw error=error sending request for url (https://redacted:28088/services/collector/raw?event=up)

The https urls do work.

Did you try to send data to your endpoint, for instance with curl, from the same machine?

Try sending to a public url (i really like https://webhook.site for this purpose - it’ll generate a custom URL for you to watch your posts).

If this doesn’t work, then it’s an integration issue, if it does work, then it’s probably with whatever server you’re sending to.

1 Like

Yep, I tried it to pastebin the other day and it worked just fine so I know the integration itself is working, I just can’t figure out why the integration isn’t working when sending data to cribl, even though if I do it as a curl from the server it works just fine.

Yes, sorry I meant to put that in my post, I did do a curl -k and it worked just fine.

So if I log into the server and do a curl with the following format:

curl -k “https://cribl-prd.(redacted.com):28088/services/collector/raw”
-H “Authorization: (redacted)”
-d ‘{“event”: “test data 1”}{“event”: “test data 2”}’

I see data coming into splunk. However, if I configure the integration with:

Payload encoding = JSON

URL: https://cribl-prd.(redacted.com):28088/services/collector/raw

Header
Authorization : (redacted HEC token)

Nothing shows up.