Chirpstack network server repository

Can someone give me the current URL for the latest version. The one in the documentation isn’t working.


all working by this URL

Where is the broken link you’re referring to? Just curious, so we can fix it :smile:


I may be doing this all wrong. It’s been around 5 years since I have worked on Linux. I had been working fiber DWDM networking but I am glad to back on Linux.

I started from the network server download page. It appears to me you have 3 options, download binaries, download packages, download repository.

I tried to post but it said new users can only put 2 links in a post.

I have always used repositories so I am trying to take that path. I followed the setup on the download page. I had to erase the steps on the download page due to being a new user
sudo apt-key adv
sudo echo
sudo tee
sudo apt update.

It gets 12 packages 11 from ubuntu and 1 from stable InRelease but although I don’t get an error message the package isn’t installed. If I browse the repository the package isn’t in the URL artifacts.chirpstack…

I hope this is clear and I feel like I was making a mistake. I did get the package installed by downloading the package to my pc then moving it to the server and using dpkg.


are you read this chapter?


Yes I have read it many times. I did get the package installed and running by using the download link. I was then able to get it running using the dpkg command.

Thank you