ChirpStack Node-RED nodes

I have just released a ChirpStack Node-RED nodes package, which can be used to received uplinks from ChirpStack (using MQTT) and schedule downlinks using the ChirpStack gRPC API. Instructions on how to use this package can be found here: GitHub - brocaar/node-red-contrib-chirpstack: ChirpStack Node-RED nodes.


which node did you choose to insert the device event? I installed the chirpstack package, but I couldn’t find this node. I need your help please!

It uses the MQTT node, which is already provided by Node-RED. While it is aimed at ChirpStack Gateway OS uses, this might be helpful: Node-RED quickstart - ChirpStack open-source LoRaWAN<sup>®</sup> Network Server.

1 Like

So from what I understand, I have to install the geteway OS on my gateway first?

Not my take: you just need to install THIS add-on to integrate with ChirpStack into your existing Node-RED. MQTT node comes with Node-RED already but you do need to configure it to subscribe to your ChirpStack.

I’m trying to install this without too much luck. But I had to upgrade a lot of Node-RED modules (last did that 3 yrs ago :rofl:) so I’m a little behind the times.

Had to put in ticket for IT to retire Win7 virtual server and spin me up a Win10 version. Oops. :crazy_face:

for the configuration of MQTT with chirpstack I did this
For the installation I followed the link you gave me, and it gave me these nodes

But I can’t find here the device event node :pensive: :pensive

These are not the nodes provided by GitHub - chirpstack/node-red-contrib-chirpstack: ChirpStack Node-RED nodes

@brocaar, so I was about to post that I got same result as @Nabila only to realize my mistake: I had previously used Node-RED palette to install a package that’s available from their repository (that’s what the blue nodes are) called chirpstack (lower case) while your nodes are “ChirpStack” (mixed case) installed using npm:


Here are both packages:

Easiest way to see what’s going on is to go to top-right of Node-RED UI, click on “hamburger” and select Manage Palette:

bruh i still dont understand how you manage to install the non-blue shirpstack using the npm installer to only get errors

Can you post errors you’re getting?

I can tell you that I first had to get a newer Node.js (which required a newer version of Windows; newest Node.js didn’t support Windows 7) and then I installed most recent nodeRED and everything else was pretty smooth after that, except for what I said about chirpstack vs ChirpStack.

I’ve installed new updated chirpstack node-red nodes but can’t make it running?! I did it some time ago, prior update , fallowing the instructions and it was running properly. Now I get enqueue error as shown on the figure.

How can I troubleshoot this error?

Is there any missing instruction for this new updated nodes?
I wander why is changed DevEUI to DevEui?!

best regards,

This was version issue! I was using newly published V4.0.0 chirpstack up/downlink nodes with prev version of chirpstack network and app servers.
When installed @chirpstack/node-red-contrib-chirpstack@3.0.1 both, up and downlink messages work smoothly as before.
Anyhow I’m still curious to know how to troubleshoot enqueue error (and other type of errors) when happens.

1 Like

can you send the contrib v3 installation tutorial?

There’s no any special tutorial, you should fallow, just force installation of 3.0.1 version with
npm install @chirpstack/node-red-contrib-chirpstack@3.0.1

1 Like

and be sure that you properly deleted previously installed version.
Check it with npm list -g if you install it as global
If you still see old version in palette manager do restart Node-red. I use pm2 for that. br

Hi @nensak ,
what version of node.js and node-red are you using? I already forced the installation with npm install @chirpstack/node-red-contrib-chirpstack@3.0.1 , restarted node-red, and I still do not see any of the ChirpStack nodes available. When I search on the “Manage Palette” section, I only see the nodes available from @smartparks but nothing from @chirpstack.
Thank you!

1 Like

I have solved it after many restarts of node-red.

  1. cd ~/.node-red
  2. ls
  3. cd node_modules
  4. git clone
  5. npm i node-red-contrib-chirpstack
  6. node-red restart
  7. Close web session
  8. Reopen. They should appear after restarting node-red.

Make sure you have Node-Red version 3.0.1 and stable version of node.js, which is v16.16.0 as of now.

1 Like

the ‘echo function’ examples above and throughout the documentation make sense as the foundation for a class A device but I’m looking to initiate downlinks on an ad-hoc basis for a (timing insensitive) Class C device which necessitates constructing the downlink message without the aid of an inbound message. I’ve had this working previously but am now screwing it up somehow, as the downlink node reports an error “devEui is undefined”.

I’m constructing the input in a function node in the form:

msg.payload = {
devEui: “a840535318187fa”,
confirmed: false,
fPort: 4,
data: ‘08ff’,

return msg;

Can anyone point to an example function node that does work?
using ChirpStack 4.01

So I’ve upgraded to 4.0.2 and downlinks are now working with no change to the function node code.

But i still get [different] unexpected output from the downlink node:

msg : undefined

Should this not be returning the downlink ID? I can see that in other respects the downlink is definitely working.

I wander if anyone managed to make downlink working in node-red-contrib-chirpstack@4.0.0?!
I did it with version @3.0.1 and with chiprstack V3 but now I can’t repeat it again.
On @4.0.0 I could not make it at all, as I suppose that @4.0.0 must be used with chirpstack V4, and can’t run with V3?
I saw that porzim posted an issue on github and have got an attention of brocar, so I hope this will be solved soon.
I just want to stress that I keep this as very important element of entire chirpstack infrastructure. When looking on TTN there are many resources related to using Node Red in many scenarios. We are lacking any progress in this topic. SSome real example would be of great help if anyone can help?