ChirpStack OS - Static IP, layered filesystem

How can I set a static IP in ChirpStack OS? The most obvious way, modifying
does not work. The modified file is saved correctly in the layeredFS, but ignored at startup. I do know workarounds for this, but I am really interested in the origin of this problem.
One option would be that the interface-configuration is set up before the layeredFS. Hardly denkmöglich, since the layeredFS should be available at a very low runlevel …

Hi John,

Did you ever found the root cause? I am trying to figure out how to set a static IP address in Chirpstack. So far I was not been able to find a way to configure the static IP@ (changing the /etc/network/interface does not work)

Hi DeBuffel,
Unfortunately I didn’t find out why setting a static IP in /etc/network/interfaces does not work. What I finally did was setting up concentradord and gatewaybridge on a raspbian lite.

That is really a shame that it cannot be used in the Chirpstack OS. So know now created your own single Rpi OS containing all chirpstack elements right?

Maybe I should also consider doing that.

Thanks for your feedback

Yes I did. ChirpstackOS seems to be very solid and reliable, but if you need custom elements, it starts getting messy. No apt, no fun.
Another problem with busybox is the dropbear ssh server implementation, which is not compatible to all ssh-clients, see Poor Dropbear SSH Implementation?.

Great. I also am considering your approach and leave ChirpStackOS for what it is and take the more flexible env.

I added an external DHCP server as I could not get the static IP to work.
If anybody did I am still eager to learn how to implement it on the fullChirpStackOS :slight_smile: