Chirpstack Server doesn't work

To be honest, it’s driving me crazy.
I finished a day yesterday with a completely working set. I closed chirpstack with the command “sudo poweroff”. The screen was black, so I switched the power down.

This morning, I switched the power on the RPi, and at the bottom of the screen, I saw a message: “no DMA platform data,” and clicking on the keyboard gives no action.

Ping doesn’t respond to chipstack IP address. I see chirpstack IP on my router DHCP list.

What is wrong? What should we do to achieve a stable environment of chirpstack?

Could be a problem with your RPi/hardware, or storage, or perhaps filesystem? If the device doesn’t finish boot and pick up an IP address, the probably is likely lower level than ChirpStack itself.

My RPi 4 was damaged, probably after powering off on this device. I asked about the command to shut down Chirpstack OS v 4. I made another topic about this topic. I’m in the test phase of my Lora wan, and I want to power off this device occasionally. I have RPis from version 2 to version 4. I have never had such a problem. I always call the sudo shutdown command and then power off. But I don’t know how to power off on the Chirpstack OS.

I changed different SD with different OSs (Raspberry Pi OS 4 and Ubuntu LTS), but I got the same error message.

I tried to use my old RPi 3 from the drawer; I made a new SD for Chirp stack OS v 4 (I found the same image for all Rpis). OS started, but It couldn’t recognize RAK 5146 concentrator (Gateway ID: could not read gateway_id).
So I’m a little bit frustrated this day, from the morning.

Are you certain that your RPi is getting suffient power?
I have those Semtech IOT Starter kits, which are RPi 2B boards integrated with a HAT that has a SX1301 chip. These seem to be rather power-hungry, especially when transmitting (where the board can crash).

My IoT infrastructure contains two devices. RAK 5146 as a hat on the RPi 3 and WIO E5 Mini. RPi is supplied with a power outage, so there isn’t a problem with the power supply. The end device is in the testing phase, but it will be supplied from the batteries in the production phase. This device is planned to run in the low power mode, so I don’t expect a problem with the power supply.