Chirpstack ui modifications

I would like to make some slight changes to the webui I use chirpstack-docker, so the changes i need to make are not in this repo.

I cloned the chirpstack repo and made some changes to the dash which i want to check what they look like, but i’m not sure how to do that properly?

i ran the make command which seemed to build it, but on trying to add it into the chirpstack-docker compose it just crashes on start.

How do i go about doing this?
Or do i need to compile the entire project and containers myself for this to work from the chirpstack repo?

tried to compile the entire project on my old machine here at home, is this correct way to try and compile it all. following the steps on the chirp repo (using docker nix) i seem to get the following error after compiling and loading all the dependencies.

Please see the following instructions for building ChirpStack from source:

I tried a day or so after that, but i kind of gave up as compiled languages really are confusing to me it seems :smiley: this was the failed build log on 4.5.0.

Is this correct way brocaar, i think it looks like some kind of dependency issue?

initially i tried this as i do not use nix. the only way i could get it to compile anything which seems is the wrong way was to call make in the first level chirpstack directory

At the top of your screen, the problem is that you don’t have Docker Compose installed. At the bottom, you moved into a “chirpstack” sub-directory, where the Makefile isn’t located. Unless you know why, the normal way is to stay at the level with the Makefile, whenever you run “make”.

argh yes i remember how i got past this now last time i have a newer version of compose.

i have run it through docker compose and nix now - installed nix after that post this is the same error as in this log file.

the only thing that triggers any kind of build is to run make from the chirpstack base directory. lmk what the heck i’m doing wrong if you know.

Looks like i got it to build the default webui… how do i go about containerising it as the webui over the default chirpstack-docker one if I make some changes and compile it.

made it this far…
i copied the links over to chirpstack-docker compose.yml…
with links to the build container, but it fails on start.

      context: /home/cory/chirpstack/ui
      dockerfile: Dockerfile-devel
      - /home/cory/chirpstack/api/grpc-web:/chirpstack/api/grpc-web
      - /home/cory/chirpstack/ui:/chirpstack/ui
      - "3000:3000"

the regular interface at 8080 is accessable, but the one on 3000 kinda dies on startup…
chirpstack-docker-chirpstack-ui-1 exited with code 0

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.