Chirpstack v4.6.0 missing uplink info latest gw bridge

I have tried a few times to update to latest gateway bridge but I get these errors and cannot upgrade it past 4.0.9 or 4.0.10 I have it on tag version 4 at the moment. Is there anything I can do to fix these errors? the latest gw bridge just seems to fail to pass any uplink or downlink data from helium or private gateways altogether.

chirpstack-docker-chirpstack-1        | 2024-01-12T08:28:56.977789Z  INFO chirpstack::gateway::backend::mqtt: Message received from gateway region_id="au915_1" topic="au915_1/gateway/2864afc74baa57f1/event/up" qos=0 json=false
chirpstack-docker-chirpstack-1        | 2024-01-12T08:28:57.180429Z  WARN chirpstack::uplink: tx_info of uplink event is empty, skipping
chirpstack-docker-chirpstack-1        | 2024-01-12T08:28:57.180469Z  WARN chirpstack::uplink: tx_info of uplink event is empty, skipping
chirpstack-docker-chirpstack-1        | 2024-01-12T08:28:57.180702Z ERROR chirpstack::uplink: Deduplication error error=Unable to get first item from rx_info

Could you create a GitHub issue with all the relevant information to reproduce this?

I run chirpstack via docker, so anytime I use the tags latest for chirpstack and chirpstack-gateway-bridge I see this problem - this is not a v3 to v4 upgrade. I just rebuilt this LNS with v4 from the start.

I see master has it containers still set to tag 4, is this on purpose?

4 is inclusive of 4.6 and 4.6.0.

I would of thought that as well @bconway, but if i change it to latest it pulls a different container altogether with a different container hash too even, this is what I see for chirpstack - i only get this error on the latest container for gw bridge below if that makes sense.

chirpstack/chirpstack                   4       a0bb42598a8b   6 weeks ago    55.3MB
chirpstack/chirpstack                   latest  a0bb42598a8b   6 weeks ago    55.3MB
chirpstack/chirpstack-gateway-bridge    latest  375ef145630c   4 months ago   20.6MB
chirpstack/chirpstack-gateway-bridge    4       be4b06183bd2   6 months ago   21.1MB

According to the tags here:

latest matches the v3 branch (may not be intended, it’s the most recent push), and I don’t see one that matches the hash you have for 4?

I cant explain that, thats what gets pulled when i pull the containers with the 4 tag look.

same ones are pulled to my test lab, how can they not exist? what is going on here?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.