ChirpstackOS - as standalone with no internet

Hi,

Currently running the full ChirpStackOS on a single RPi4 and another RPi4 is running an MQTT client handling the device info. That all works great and stable (when internet connection is there …).

My idea is to have the Chirpstack running as stand-alone. As said when the internet is no longer connected the ChirpStack is not fully operational.

1> Webaccess partially works. Often errors “Context deadline exceeded Code: 2”). E.g. live traffic from the LoRaWAN gateway can no longer be seen.

2> External MQTT client does not receive any messages

Look like internal communication is somehow failing. Does anybody have an idea what is causing this and how it can be solved?

1 Like

Have not been able to solve this. Seems to be related to DNS / resolving the localhost name to 127.0.0.1.
Suggestions are welcome.

To get the GW to work as standalone (without internet) a first step is to disable the DNS proxy that connman uses. Below the steps I followed:

  • cd /etc/init.d
  • sudo nano connman
  • Add --nodnsproxy as parameter
  • In the following line: $DAEMON $EXTRA_PARAM --nodnsproxy
  • sudo reboot

Now the issues remains that AS URL becomes slow (we probably are waiting for time-outs)
Will be doing some tests over the weekend.

To be continued …

Any final conclusion on this topic? Or do you have any suggestions what to look for? I’m having the same problem.

All the “map” stuff is probably not going to work. A quick look at the dev_console in my browser points to openstreetmap. For that to work you’d need to also host a tile-server. For the DNS Issue, you could try mDNS: https://www.howtogeek.com/167190/how-and-why-to-assign-the-.local-domain-to-your-raspberry-pi/
should “just-work” in a “.local” environment.
I dont know if the Chirpstack Image already supports it.