Confirmed message send but can't receive ack

  • End node device setting -
    Activation : ABP
    band : US902-915
    ADR : ON
    Channel : 0-7(902.3Mhz~903.7Mhz)
    App Payload size : 28
    DR : 3
    RX2 Channel :923.3Mhz
    RX2 DR : 13
    TX Power : 20

I’m using RAK811 LoRa Module. And I’m using rhf0m301 module and semtech pakcet forwarder for gateway.

ConfirmedDataUp is displayed only for the first uplnik message after turning on the end node device,
and subsequent messages continue to display UnconfirmedDataUp.

And Unconfirmed data is null…

This is caused by the inability to receive ack from the LoRa Network Server.

In LoRaWan Gateway Terminal window, the following message is displayed.
A downlink was already scheduled, overwriting it.

Why is this happening?

Please check if there are any wrong with lora server setting.

In my personal view, I think ther is no problem with node device and gateway.

Because I succeeded when i tested it on The Things Network.

These are the results of a test on The Things Network.

and end node device debug window and downlink message

Why can’t and end-node device receive a ack?

Downlink is essential in the system being implemented.

1 Like

I am also facing the same issue.

End node is not receiving any ack from Network Server. May I know what could be the possible reason?

@vinsanity let me know if you have solved the issue

1 Like

Is this problem solved ? I have same issue too.

Im having similar issues, any updates on this?