Context deadline exceeded (code: 2)


I know that there are lot of topic with this error however the context is a bit different.

maybe you can help me, this morning I wanted make a backup of my loraserver.
From my synology NAS I cloned my virtual machine (Debian 9) , I started my loraserver cloned and I modified its local ip: vs

I did it in case where I want update my loraserver without to stop the loraserver in production…
Bad idea :frowning:
I started both in same time loraserver hosted in and loraserver hosted in (it have the same configuration files only the adress ip was different).

Since I started both I recovered an error my loraserver web interface ==> context deadline exceeded (code: 2)

My troubleshooting:

  • I stopped the loraservers and I restarted only the loraserver in production ( ==> same error
  • I restarted my VM and also my NAS ==> same error
  • I deleted my VM cloned ==> same error

here some logs status of loraserver and lora-app-server:

journalctl -u loraserver -f -n 50

journalctl -u lora-app-server -f -n 50

I don’t understand what’s going on I didn’t change any certificat or anything else…

Here some logs of the network (why the lora-app-server appears lot of time?)

I also perform some kill of pid but nothing work…

I realy need some help…

Problem solved after re-installing TLS certificate:

Network-server API
Default join-server settings.
Settings for the “internal api”
oin-server configuration.