Creqating a Gateway with the API Error

Hello, i am trying to create a Gateway with the API . I am sending this object to the /api/gateways endpoint by a post message

“gateway”: {
“id”: “b827ebfffe912a54”,
“name”: “test”,
“organizationId”: “1”,
“serviceProfileId”: “d17e62bc-2722-4c9b-8849-83dc9de6075d”,
“gatewayProfileId”: “1c6cd602-5012-4de0-a5c9-d83a366274b6”,
“networkServerId”: “1”,
“description”: “test”,
“location”: {
“accuracy”: 0,
“altitude”: 0,
“latitude”: 0,
“longitude”: 0,
“source”: “UNKNOWN”

and i get:

“error”: “object does not exist”,
“code”: 5,
“message”: “object does not exist”,
“details”: []

I tried everything, i dont know why is not working.
serviceProfileId, gatewayProfileId, networkServerId and organizationId already verified.

I solved…the problem was the name of the fields:

organizationId must be organizationID
serviceProfileId must be serviceProfileID
networkServerId must be networkServerID
gatewayProfileId must be gatewayProfileID

@brocaar this can be fixed? because in swagger, the everything is in camel case, i figured out about this because i made a get of one gateway, and i saw the difference and i felt very bad…ajajjaja

Looking at the naming, I assume you are using v3, not v4. Please note most of the development effort is now focused on v4 (which has been out for ~ 1 year already). Feel free to create a pull-request in case you see an issue with v3, however I would suggest migrating to v4 as it contains many improvements over v3.