Custom channels


I am trying to work with a node operating in the following frequencies: 865.1/865.3/865.5
In order to achieve that I performed the following steps:

  1. configured my gateway’s config locally on the gateway (not Chirpstack related)
  2. created a new gateway profile with:
    • enabled channels: 0,1,2
    • extra channels: 8651000, 8653000, 865000

I cannot receive any frames! Am I missing something in configuration?

Thanks in advance.

865.1 MHz = 865100000 Hz

@eugenev it was a typo! I meant 865100000, 865300000 & 865500000.

Any other ideas?

is your endnode device successfully joins to the network ? join process must be on standart frequency band channels. extra channels applied after join.

No! I do not see any LoRaWAN frames on Chirpstack.
The end node only supports the aforementioned channels.

Is there any other part of the configuration that I should modify?

I suppose this is India LoRa frequencies ?
is your gateway supports this frequency channel plan? is it properly configured ?

As a matter of fact it is an older frequency plan no longer described in the regional frequency plans of LoRaWAN specs. However, it is part of the EU868 band so the radios of the GW definitely support it.

and this frequency channels configured in the gateway?

Yes of course! it should not be an issue of the GW, but rather something I am missing with the Chirpstack’s config.

Please note that all 86x channel plans (EU, IN, RU) have some default channels which MUST be implemented in every end-device, so the first thing I would suggest is to keep your device compatible with specification. That will save you some trouble at least. Also make sure you meet regional ISM band limitations.

Now, if you select a frequency band in network server config, those default channels will be enabled by default and will be always present. It means that you will always have channels 0, 1, 2 predefined (for EU868), so you have to define your custom channels as extra channels 3, 4, 5 in your network server config. I would suggest to configure the gateway’s channels in the same way.

The there can be problems with device activation or join requests, but you can try this first and you’ll see if it does something.

Where do I perform this server config? Is it somewhere in the GUI apart form the gateway profile or should I modify a .toml file as well?

Yes, in .toml file, see the [[network_server.network_settings.extra_channels]] in for example.

I personally do not use gateway profiles at all for now (with gw-bridge on server).