Database migration error when upgrade AppServer, NetworkServer, GB versions

Hi, we faced the DB migration issues when tried to upgrade chirpstack appserver, network server and gateway bridge from 3.10.0 -> 3.14.0 (app server), 3.9.0 -> 3.12.1(network server) and 3.9.2 -> 3.10.0 (gb). App failed to start with error message: “Dirty database version 1. Fix and force version.”

How can this be solved?

Are you sure you are using a tagged release? :latest is following the master branch… I’m assuming this because currently there is some work being done on the database migrations which could have caused such error.

1 Like

We are not using :latest to avoid problems with new upgrades. Definitely were used tagged images

Ok, it was my bad. The issue was actually with the new FUOTA service, which we run on the same DB instance as the other services. To avoid this situation either run FUOTA using another DB or first, run app-server/network server, then apply migrations from the FUOTA to the DB manually and only then start FUOTA service.


I would recommend to use different databases for each service (could be using the same PostgreSQL instance) :slight_smile: